2 edited body
source | link

One option would be to set Languages.AlwaysStripLanguage = false in config settings.

This would cause the Sitecore.Pipelines.PreprocessRequest.StripLanguage processor in the preprocessRequest to not try and resolve any languages embedded in the URL and instead trying to match them as content in the tree. If you don't have items named en or de-DE in the tree then this will in turn throw a 404.

You may also want to set languageEmbedding = never in the LinkManager, and only set these values on the CD servers.

When you're ready to go live then remove revert/revert the above settings.

If you want to keep the en part in the URL then you could create a custom StripLanguage processor to only interpret specific languages.

One option would be to set Languages.AlwaysStripLanguage = false in config settings.

This would cause the Sitecore.Pipelines.PreprocessRequest.StripLanguage processor in the preprocessRequest to not try and resolve any languages embedded in the URL and instead trying to match them as content in the tree. If you don't have items named en or de-DE in the tree then this will in turn throw a 404.

You may also want to set languageEmbedding = never in the LinkManager, and only set these values on the CD servers.

When you're ready to go live then remove revert the above settings.

If you want to keep the en part in the URL then you could create a custom StripLanguage processor to only interpret specific languages.

One option would be to set Languages.AlwaysStripLanguage = false in config settings.

This would cause the Sitecore.Pipelines.PreprocessRequest.StripLanguage processor in the preprocessRequest to not try and resolve any languages embedded in the URL and instead trying to match them as content in the tree. If you don't have items named en or de-DE in the tree then this will in turn throw a 404.

You may also want to set languageEmbedding = never in the LinkManager, and only set these values on the CD servers.

When you're ready to go live then remove/revert the above settings.

If you want to keep the en part in the URL then you could create a custom StripLanguage processor to only interpret specific languages.

1
source | link

One option would be to set Languages.AlwaysStripLanguage = false in config settings.

This would cause the Sitecore.Pipelines.PreprocessRequest.StripLanguage processor in the preprocessRequest to not try and resolve any languages embedded in the URL and instead trying to match them as content in the tree. If you don't have items named en or de-DE in the tree then this will in turn throw a 404.

You may also want to set languageEmbedding = never in the LinkManager, and only set these values on the CD servers.

When you're ready to go live then remove revert the above settings.

If you want to keep the en part in the URL then you could create a custom StripLanguage processor to only interpret specific languages.