We’re rewarding the question askers & reputations are being recalculated! Read more.
4 added code highlights
source | link

Configure the site node in IIS to add the new host name binding.

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MBfilteredItemsCacheSize="10MB"
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

Configure the site node in IIS to add the new host name binding.

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

Configure the site node in IIS to add the new host name binding.

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB"
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

3 added code highlights
source | link
<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>
<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>
<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>
<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>
2 added 68 characters in body
source | link

Configure the site node in IIS to add the new host name binding.

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

Configure the site node in IIS to add the new host name binding.

Create a patch file to patch in a site node to the /sitecore/sites configuration section.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <sites>
      <site name="site" 
            patch:after="site[@name='modules_website']"
            targetHostName="site.hostname.com"
            database="master"
            virtualFolder="/"
            physicalFolder="/"
            rootPath="/sitecore/content/site"
            startItem="/Home"
            domain="extranet"
            allowDebug="true"
            cacheHtml="true"
            htmlCacheSize="50MB"
            registryCacheSize="0"
            viewStateCacheSize="0"
            xslCacheSize="25MB"
            filteredItemsCacheSize="10MB
            enablePreview="true"
            enableWebEdit="true"
            enableDebugger="true"
            disableClientData="false"
            cacheRenderingParameters="true"
            renderingParametersCacheSize="10MB"
            enableItemLanguageFallback="true" />
    </sites>
  </sitecore>
</configuration>

Change the values for targetHostName, rootPath and startItem to match for the site you are configuring.

Place the patch config in App_Config/Include/[folderNamePerStandards]

1
source | link