We’re rewarding the question askers & reputations are being recalculated! Read more.
2 added 710 characters in body
source | link

In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below:

Invoke-ManageWebsiteTask : The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have tried to start the website manually through IIS Manager, but it gives me the same error:

enter image description here

Find below the screenshot of the Powershell script execution:

enter image description here

Does anyone have any idea of what is going on?

Update: How I got it fixed?

Firstly, thanks, @artsem-prashkovich and @viet-hoang for the suggestions. You've helped me to figure it out.

Please, find below the steps that I did to get it working:

  1. Restart OS
  2. Stop "Sitecore Marketing Automation Engine" and "Sitecore XConnect Search Indexer" services.
  3. Manually delete the created users from the following databases _Processing.Pools; _MarketingAutomation; _ReferenceData. Each database has its own user: poolsuser, marketing automation user, referencedatauser
  4. Re-run the Powershell installation script

Voila!

enter image description here

In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below:

Invoke-ManageWebsiteTask : The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have tried to start the website manually through IIS Manager, but it gives me the same error:

enter image description here

Find below the screenshot of the Powershell script execution:

enter image description here

Does anyone have any idea of what is going on?

In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below:

Invoke-ManageWebsiteTask : The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have tried to start the website manually through IIS Manager, but it gives me the same error:

enter image description here

Find below the screenshot of the Powershell script execution:

enter image description here

Does anyone have any idea of what is going on?

Update: How I got it fixed?

Firstly, thanks, @artsem-prashkovich and @viet-hoang for the suggestions. You've helped me to figure it out.

Please, find below the steps that I did to get it working:

  1. Restart OS
  2. Stop "Sitecore Marketing Automation Engine" and "Sitecore XConnect Search Indexer" services.
  3. Manually delete the created users from the following databases _Processing.Pools; _MarketingAutomation; _ReferenceData. Each database has its own user: poolsuser, marketing automation user, referencedatauser
  4. Re-run the Powershell installation script

Voila!

enter image description here

1
source | link

SIF installation process fails because it cannot start website

In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below:

Invoke-ManageWebsiteTask : The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have tried to start the website manually through IIS Manager, but it gives me the same error:

enter image description here

Find below the screenshot of the Powershell script execution:

enter image description here

Does anyone have any idea of what is going on?