All Questions

0
votes
1answer
10 views

Checking if a general link is empty within a partial view

I can display a link from a field but I only want to display the link if it's been filled out by the user. I tried surrounding by a conditional statement and checking for the field being null, but ...
0
votes
0answers
5 views

Solr: datetime fields appear garbled in Solr

I'm on Solr 4.10.4, Sitecore 8.1 160519. I have a custom index defined the following way: <field fieldName="date_of_birth" returnType="datetime" type="MyProject.Search.ComputedFields....
1
vote
2answers
53 views

Sitecore Powershell Extensions not returning field source value

I'm trying to write a simple Powershell script that finds all General Link fields and outputs the value of their Source field. $fields = Get-ChildItem -Path "master://sitecore/templates/user defined" ...
1
vote
1answer
21 views

Is it possible to create sub-sections within your field sections?

Is there a way to create sections within your field sections? - Field Section - Field For example I would like the following template setup to be like this: - Header - Header Title - ...
0
votes
0answers
9 views

Unexpected response from import service: Error: getaddrinfo ENOTFOUND http http:80

I am getting following error Unexpected response from import service: Error: getaddrinfo ENOTFOUND http http:80 "while running this command " jss deploy app --includeContent --includeDictionary" ...
0
votes
2answers
43 views

Pesonalization rule for the page - not component level

is there any way to show the separate page based on personalisation rule? i need to show one page when the user is authenticated and another page when user is not authenticated. Personalisation is ...
0
votes
1answer
8 views

Newly created JSS react app does not start and show blank page

The newly created JSS react app does not start. It shows completely blank page and shows error in the console while accessing the public URL i.e. http://jssreactweb/, Using fresh install of Sitecore 9....
0
votes
1answer
15 views

Tracking and identifying multiple users on the same session

Sitecore's documentation always talks about how the same person comes back to the site and is identified. How are multiple persons handled? Say that a person first enters the site (anonymous tracking)...
2
votes
0answers
17 views

Does Sitecore Forms meet the standards from WCAG 2.1

Do the Sitecore 9 forms meet the standards from WCAG 2.1? I've read that they meet the 2.0 but couldn't find anything around 2.1. Any documentation that I could have a look?
0
votes
1answer
32 views

Sitecore 9.1 and Active Directory compatibility question

I was looking into installing Sitecore 9.1 and was reviewing the modules compatibility table for XP (https://kb.sitecore.net/articles/541788) and was surprised to see no support for Active Directory ...
1
vote
1answer
26 views

Solr and Tokenizers: how to tokenize specific indexes using Solr 4.10.4

I'm on Solr 4.10.4, Sitecore 8.1 160519. I finally managed to convert my Lucene custom index configuration to Solr, but some indexes are not tokenized. The custom index "parsed_answers" on Lucene is ...
0
votes
1answer
25 views

Cortex Content Tagging vs Marketing Taxonomies

Hello fellow Sitecoreans, Hoping someone can answer these... Does Cortex Content Tagging replace Marketing Taxonomies in Sitecore 9.1? If not, in which scenarios would each apply?
0
votes
0answers
23 views

How to replace an item with another item by ID in Treelist field using Powershell?

I want to replace an item with another item in a Treelist. Basically, the items I want to replace are broken links. Suppose, There are two items A and B. A is used in a Treelist field, so I want to ...
0
votes
1answer
26 views

Sitecore EE Ctrl+Click equivalent for Mac

In the Sitecore EE on a Windows machine you can hold the ctrl key and then click on a link to force Sitecore to navigate to the link. What is the equivalent on Mac? We have tried "CMD+click", "ctrl+...
1
vote
0answers
22 views

FatalError Required validation not working

I am using SXA 1.8, and Sitecore 9.1 I am trying to add a validation for a Date type field where it is required, and the user cannot save the item unless this field has a value, I have copied ...
2
votes
1answer
27 views

YSOD When trying to open the login page - “No process is on the other end of the pipe”

I have 12 different instances (test purpose only) using this same SQL Server. All of the sudden, one of those (which was working fine until yesterday) started giving me this error when I try to open ...
2
votes
1answer
46 views

SXA & Language fallback in list components

I have a website with SXA (1.7.1) and language fallback setup up. It all works fine for regular components (eg. carousel or a custom component made by us) but lists (eg. Link List) won't pick up ...
1
vote
0answers
23 views

Couldn't trigger custom event handler or Processor in Sitecore Publishing Service?

I have a requirement to invalidate the file in cdn cache on completion of sitecore item publishing. To achieve this I have created custom processor and patched into "publishEndResultBatch" pipeline, ...
0
votes
0answers
26 views

Insert javascript to link not working as expected

Using insert javascript on link field, adds javascript code to a tag in href with return false which is added automatically and because of it mistake appears and if manually delete return false ...
0
votes
2answers
44 views

Re-adding Site Module to install new SXA components

I have followed the instruction here https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/copy-and-customize-a-rendering.html and through some you tube video with adding a ...
0
votes
1answer
16 views

ModuleNotFound error throws when deploying files

ModuleNotFound exception throws when deploying css file. I have started to explore Sitecore-Jss and deployed sample app in the sitecore and it works fine. I just added a new css file (test.css) under ...
0
votes
1answer
20 views

SXA - Tenant and Site Setup - Description of Modules

I am setting up a new Tenant and Site and am looking for an explanation of the different Modules that can be installed against the Tenant / Site. I want to only install the minimum required modules ...
0
votes
2answers
35 views

Enable-WindowsOptionalFeature failed when running Prerequisites.ps1

While installing Sitecore 9.1, I'm getting an error when I run Install-SitecoreConfiguration -Path C:\resourceFiles\Prerequisites.json I ran Update-Module SitecoreInstallFramework before installing ...
0
votes
1answer
16 views

Sitecore FakeDB Deserialisation and Unicorn

Using Sitecore 9.0.1, Im looking at using Sitecore Fake DB for unit testing. Im interested in using the Deserialisation extension so that I can test using content that's been serialised to disk ...
1
vote
1answer
17 views

TDS creating duplicate properties for component in TdsCodeGen.cs

For some reason, TDS has started creating duplicate properties for one of my "constants" partial classes as well as the associated interface in my TdsCodeGen.cs. It's only doing it for one component. ...
1
vote
1answer
24 views

Solr log: Multiple values encountered for non multiValued field _basetemplates_s

I'm on Solr 4.10.4, Sitecore 8.1 160519. The configuration of the custom index is <field fieldName="_basetemplates" returnType="string" multiValued="true" storageType="yes" indexType="untokenized"...
0
votes
0answers
28 views

Experience Profile No Search Results

I am running Sitecore 9 update 2 on Azure Web App, with Azure Search. I can see Profile data when I open Experience Profile, but when I try and search for any contact I get no results? (I know there ...
0
votes
1answer
45 views

Sitecore upgradation from 7.2 to 9.0

I have used express miration tool from 7.2 instance to 9.0 instance excluding bin folder. As bin folder have sitecore and application dll's which are many. Can someone give me idea how to migrate ...
0
votes
0answers
10 views

Custom FIlter for segment in Analytics Report not working

I'm trying to create a custom segment with a custom filter following the guide from the document link. Specifically I'm trying to create a new segment for the internal search keyword to only get the ...
1
vote
0answers
28 views

Code Generation with multiple Base Template References

We are using T4-Templates to generate Code for all of our models. We have a multi project setup with multiple TDS projects. We want to use multiple Base Template References (Multi-project Properties) ...
0
votes
0answers
18 views

How to disable Sitecore item full path to load when accessing it via URL? [duplicate]

I have a multi-site solution and I can access the other item of the other site by forcing the URL of the item. Example: Site1 = site.com/us Site2 = site.com/eu Site1 root path in site definition is ...
0
votes
0answers
20 views

Template To be deleted is in use (upgrading sitecore 8.1 to 9.1)

I am upgrading my freshly installed sitecore 8.1 instance to 9.1 and i am receiving an error and two warnings after analyzing the package showing that template to be deleted is in use.
2
votes
1answer
16 views

Set up field copy rules

I need to add custom field to Azure search schema and set up copy field rules to get the values of some other fields and set them as the values of this custom field. I can do it in Solr with Schema ...
1
vote
1answer
40 views

Sitecore Url not working - layout not found error

We have just upgraded from Sitecore 8.1 update 4 to Sitecore 9.0 update 2. Almost all functionalities are working. But we have issue with one url. When i tried to access below URL i got the Layout not ...
0
votes
1answer
27 views

How to get app name for jss dictionary

How to get app name for jss dictionary, for request /sitecore/api/jss/dictionary///. Neither throws 404 error if not using sc_apikey or Unknown app name?
0
votes
0answers
20 views

Insert Media Link Field in Multisite environment

I have a sitecore multisite environment, where five to six sites will be present in single instance. In a particular default sitecore field, with type as General Link Field : Media /sitecore/system/...
0
votes
0answers
25 views

Error Rendering View

I am trying to preview a page from Sitecore Rock, from VS but I get this error. I have a Layouts, and I have putted that layouts in _Standard Values of that page. I don't know where is the problem now ...
1
vote
1answer
22 views

Sitecore Azure indexing logs in CD server when Indexing is triggered from CM server

We are using Sitecore 8.2 update 3 on Azure Iaas. When we trigger Indexing from Control Panel(obviously from CM server), we see the indexing jobs in the logs of CD server. Does this mean that the ...
0
votes
0answers
33 views

How to call this Controllers or Action?

This action is not call in the browser! How to call this Controllers or Action?
0
votes
0answers
18 views

Integration ServiceApiController webapi with swagger swashbuckle and with APIM [on hold]

Scenario: I'm exploring web api2 with sitecore .Is there a way where we can integrate swagger swashbuckle with Sitecore ServiceApiController which indeed inherits from ApiController. I tried ...
0
votes
0answers
17 views

SXA 1.8 Event List and Event Calendar documentation [on hold]

I'm looking for good documentation on the SXA Event Calendar and Event List renderings. I'm trying to get them working but having issues. With the event list; it looks I can't configure the Date ...
4
votes
2answers
60 views

How to programmatically refresh a Sitecore item on Content Editor upon editing it

I would like to refresh a Sitecore item after editing it programmatically. Scenario: An Action of a workflow opens a dialog, does some operation and on clicking the OK button I want to refresh the ...
1
vote
0answers
39 views

Custom index, stategy to publish items under a certain path

We have this custom index that only contains pages for one section of the content tree. We want it setup so that publishing items under this path reindexes those items automatically. This seems like ...
1
vote
0answers
14 views

Solr Document Boosting

I'm attempting to item boosting working with Solr and I can't for the life of me get it to work. I'm certain that I've had it working in the past for other projects. The problem looks to be on the ...
0
votes
0answers
44 views

What if the xConnect instances are down?

Can someone please suggest that in a scaled Sitecore 9 environment for some reason if the Roles other than CM and CD are down, how the Websites will be impacted? If the xConnect, Marketing ...
0
votes
0answers
12 views

Sitecore Dual Public/Private Active Directory Authentication

I already have Active Directory authentication installed and working with Sitecore. I'm trying to set up a website that is available both publicly and privately. The private version uses Active ...
0
votes
0answers
8 views

xConnect Instances need to be Anonymous or Windows authentication?

We installed xConnect, Marketing Automation and Reference Data instances in a scaled Sitecore 9.0.1 environment. While accessing the URLs it is asking for the credentials cause the corresponding IIS ...
0
votes
0answers
15 views

Error while running Uninstall-SitecoreConfiguration SIF method

I'm trying to use SIF 2.0 to uninstall a no longer used Sitecore 9.1 instance. This method used to work perfectly with previous versions and I know that for sure since I'm quite a hard user. I don'...
1
vote
1answer
16 views

Sitecore Zip File Media Item Auto Downloads in Content Editor

I have a Sitecore media item in my media library that contains a zip file. In the content editor, when I navigate to this item, it starts the download of the zip media asset. Also, the usual zip icon ...
0
votes
0answers
10 views

Experience Editor Error - ExperienceEditor.getPageEditingWindow is not a function

When I try to use the experience editor I get an error that causes the loading sign to just keep spinning and it also prevents the Ribbon menu at the top from displaying. Heres where the error is ...

15 30 50 per page