All Questions

Filter by
Sorted by
Tagged with
0 votes
0 answers
6 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/imagepath'. Original media data will be used

We have installed Sitecore instance in Azure , we are getting (ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/imagename'. Original media data will be used) this error ...
  • 49
0 votes
0 answers
7 views

How do I correct the Build error after loading Glass.GlassMapper.sc.100 cannot find path Glass.Mapper.Sc.Start.config?

After loading Glass.Mapper.sc.100 and Glass.Mapper.sc.100.mvc (Sitecore version 10) I can no longer build successfully. I am not certain how to resolve this issue. I have loaded and reloaded the Nuget ...
0 votes
0 answers
17 views

Image Analysis error in Content Hub

In Sitecore Content Hub, we imported assets using excel with an Asset Type that triggers Image Analysis, but we got an error in the background process (processing job): Target completed with failures. ...
  • 11
2 votes
1 answer
33 views

Why is Select Media Dialog Empty When Media Exists in Folder?

When we try to Browse to select an image for an image field, nothing appears in the Select Media dialog though we've confirmed there's content in the folder designated in the field's Source attribute. ...
1 vote
2 answers
31 views

How to enable IsRobotDetection on a form?

How can I enable IsRobotDetectipn on the form while all the settings for below settings already enabled although I can't do that Xdb.Enabled. Xdb.Tracking.Enabled Analytics.AutoDetectBots.
  • 21
0 votes
0 answers
27 views

Could not find configuration node: databases/database[@id='master'] [closed]

I'm new to Sitecore. Currently, I'm trying to update a Template but I get errors when accessing the database using each of these methods. 1. Sitecore.Data.Database master = Sitecore.Context.Database; ...
  • 1
0 votes
0 answers
15 views

Get value from Js and bind to a json data attribute in cshtml [migrated]

I have a requirement to get client side data in json and pass the json in a data attribute in cshtml. Then will read the values from the data attribute. <div class="container" data-...
  • 427
2 votes
1 answer
67 views

Access denied error when creating / edit user

When I try to add new user or edit existing user and assign some role by clicking 'Member Of' tab and then edit button, I am getting below error. I am using Sitecore version 10.1.0 (rev. 005207) ...
1 vote
1 answer
33 views

Search by Contact id in Sitecore experience profile

We have enabled anonymous user tracking in Sitecore 10.1 and we can see data in experience profile with name shown as Anonymous. We want to implement the search by contact id in the experience profile....
1 vote
0 answers
22 views

How to disable Open publish dashboard button from modal popup?

Have installed Sitecore Publishing Service to separate sitecore publishing. We got one request from client only admin can able to Open publish dashboard button and for non admins this button should be ...
  • 49
1 vote
2 answers
28 views

How to download media item from media library in sitecore?

I tried to download a media item from media library to my local storage using the Item ID. But it downloaded only in cache storage. I want to download it in downloads folder. public void downloadform(...
1 vote
1 answer
24 views

Sitecore SXA not generating optimized.js file

Sitecore SXA has stopped generating the optimizedjs file when I upload the scriptminifiled.js file Any ideas what could be causing it to do so?
1 vote
1 answer
23 views

Sitecore: Foundation Project - Views Folder is not getting deployed during solution rebuild

During local solution rebuild or in Dev/QA deployments, one of my Foundation project's Views folder is not getting deployed to the webroot. Note: All the views folder from all the feature projects ...
1 vote
1 answer
38 views

How to set value in the quick info of an item in sitecore

i want to set field of Created From for an item in sitecore which appeared in the quick info section , how can i do that via sitecore or using powershell script?
  • 21
2 votes
1 answer
25 views

One Certificate for all instances in XP Scaled Installation - xDB Forbidden issue

I did an on-premise setup for Sitecore 9.3 XP Scaled environment. At the time of installation I created separate certificates using createcert.json file and common xconnect certificate thumbprint for ...
0 votes
0 answers
36 views

How can i set value of Create From field in sitecore [closed]

i want to know how to set The field of [Created From]
  • 21
1 vote
1 answer
34 views

How to add Cookies banner in Sitecore? [closed]

I would like to add cookies banner in Sitecore 9.1 version. I am using SXA 1.8. I have already added the Privacy warning in our site and would like to add cookies banner along with confirm , reject ...
  • 197
1 vote
0 answers
32 views

Restrict login between two websites with same domain [duplicate]

I have two websites www.abc.com/de-de and www.abc.com/es-es . if the user logs into the first website then he is automatically logged into the second website as the domain is same. how can I avoid ...
1 vote
2 answers
34 views

Getting Rendering Parameter in View

Is there a way to get Rendering Parameter in cshtml view file without the glass mapper model? The existing View is already using a model. So want to get the parameter without a model or glass mapper. ...
  • 427
0 votes
0 answers
24 views

Pattern cards not changing once assigned

I am using Sitecore personalization with Profile- and Pattern cards, everything is working fine and relevant pattern card is assigning to the visitors after 3 visit(default) but it seems after few ...
  • 3
0 votes
1 answer
29 views

On Sitecore form submit show pop up with yes or no button and clicking Yes save the form data

I have a requirement where on Sitecore form submit, I have to show a pop up with Yes/No option. And once I click Yes, it would call save the form data. Note: we are already using Sitecore form. and ...
0 votes
2 answers
47 views

How can I determine the source of a cloned item

I have a cloned item. I want to know which item is it cloned from (what is the source item of the clone). How can I do that in Sitecore itself or using codebehind c#?
  • 21
1 vote
0 answers
37 views

(***GUID***) attempted to be cached, but the cache already contained /sitecore/content/****

We have setup Sitecore CLI and are able to do PULL and PUSH successfully in the Dev environment. Same steps we have followed in the higher environment (PreProd) but getting below error /sitecore/...
  • 107
0 votes
0 answers
14 views

Get Selected SXA style on teaser through PowerShell script [closed]

I would like to get SXA selected style on teaser component through PowerShell script. Could someone assist me on this ?
  • 197
0 votes
1 answer
47 views

Request.IsAuthenticated is alway false in OpenId Connect

I have a requirement where the public users will click on login then it will go to SSO and after that it will redirect back to the website with details. I am using the OpenID connector for public user ...
  • 1,912
1 vote
1 answer
27 views

How to Programatically attach a Media File of System.IO.File type

We are trying to programmatically attach Media File to a Media Item at the latest version. Our requirement is to programmatically extract the file (System.IO.File) from the Local System and attach to ...
1 vote
1 answer
33 views

Redirect url with Trailing slash in the end of every url

I have a requirement where I need to redirect every URL and add trailing / in the end. Example : www.site1.com/abc should redirect to www.site1.com/abc/. Forward slash "/" should be added to ...
  • 11
0 votes
1 answer
32 views

Solr - text and string for single line text [duplicate]

Is it possible to have both a string and text index field for the same single line text field? I have tried adding my field to the DefaultIndexConfiguration config but it just takes on or the other.
  • 303
0 votes
1 answer
26 views

No data to display in Experience Analytics [closed]

I am facing a problem which is my experience analytics does not have any data showing to me. Am I forgetting to configure something or anything else?
0 votes
0 answers
14 views

Value not getting replaced during logging to Application Insight from Identity Server

Sitecore.NET 10.1.1 (rev. 005862) in Azure PAAS Scaled What I am trying to do: I want to write the logs into the Application Insights for the Sitecore Identity server. What is the current status: ...
  • 1,158
0 votes
0 answers
25 views

Using <video> tag in Sitecore rte adding &#8203 automatically [closed]

I am trying to use tag in Sitecore rte field but its automatically adding &#8203 in starting and end on html. Example : <video></video> gets changed to &#8203;<video></...
  • 11
2 votes
2 answers
50 views

Sitecore DropTree Query

I am using Sitecore 9. I am having a problem trying to populate the droptree in the template(source). The template ID for the Apple, Banana and Peach is {AB86861A-6030-46C5-B394-E8F99E8B87DB} and the ...
  • 55
1 vote
2 answers
30 views

Getting the datasource Location of all Renderings inside the page using SPE

I'm creating a script that would list down all the components in the a particular page then displays the RenderingItemName, RenderingItemID, RenderingItemPath, RenderingDatasource, etc., The script ...
  • 11
0 votes
1 answer
34 views

Why is the RTE Field adding a Zero Width Space when adding markup? [closed]

I have rte filed with video tag in this when i save the item &#8203; is getting added in starting and end of html. How to prevent rte to add &#8203;? <div class="test"> <...
  • 11
0 votes
0 answers
14 views

Unable to add in "Unable to add node_modules/.bin/acorn.ps1" [closed]

When I publish my code then it shows an error to the Web site .
1 vote
1 answer
36 views

Can't download any results from Show-ListView

I've written a script to generate a report that allows downloading a list of pages and relevant tags applied to them (within a section). In that script, I wrote the below code to download the output. ...
1 vote
1 answer
24 views

Sitecore DEF - Get the total data count

We would like to log the total records fetched from databases in Data Exchange Framework and log it in log files. How we can get the total count?
  • 153
1 vote
1 answer
42 views

IIS Rewrite Rule to redirect to new domain along with querystring parameters

I am looking for IIS Rewrite Rule to redirect from old domain to new domain along with appending querystring parameters to new domain. As I have gone through some articles but I am not getting. I am ...
1 vote
3 answers
44 views

left header placeholder in sitecore SXA

In Sitecore SXA How i create a left header placeholder as shown in the below image do i need create a custom grid layout and custom grid css
1 vote
1 answer
14 views

Sitecore 10.0 Forms Send Email action partial view error CustomTokensForm.cshtml was not found

My setup is Sitecore 10.0 in CMS only mode. My installation also has the Sitecore Forms Extension for SC9.3-SC10.0 included. I was adding forms using the Forms editor and got the point of adding ...
  • 21
1 vote
1 answer
37 views

Unable to locate the uploaded document using Sitecore Forms

I have created a Sitecore form where I am added a File Upload button and uploaded a file. Also, I have used the Save Data option to save the data to the Database once I click submit button. Now I can ...
1 vote
1 answer
34 views

Sitecore Cortex Tagging for Predefined Tags

I am using Sitecore 10.2 and also using Sitecore Cortex Content Tagging. I have different tag which is being created in Sitecore. I want to tag content that is available in tags only, I don't want to ...
  • 1,912
0 votes
2 answers
31 views

Xconnect Error after deploying custom model on Azure

I am using Sitecore 9.1 Azure. Recently I deployed the XConnect custom model and other required files on 5 roles referring to the link https://doc.sitecore.com/xp/en/developers/100/sitecore-experience-...
1 vote
0 answers
21 views

Where to find the Embedded Media Rendering after installing Brightcove Connector for 10.1.1

I have installed the brightcove connector for sitecore 10.1.1 and was able to add video using RTE's embed Media feature. But I am not able to find the Embed Media rendering in the package for the ...
  • 365
1 vote
0 answers
46 views

Errors in validating multi-level taxonomy

I created a multi-level taxonomy SampleTaxonomy in Content Hub with hierarchy below: I was pulling the serialized entities using ch-cli with ch-cli serialization pull entity -d SampleTaxonomy. Then I ...
  • 11
1 vote
0 answers
79 views

On approving asset, required field error message not showing

I am experiencing a problem related to a required field, if someone ever had this problem or has some suggestions, please let me know :) I created a DateTime type field that is required when the asset ...
  • 11
0 votes
0 answers
28 views

How to push Sitecore Application logs to Azure Storage?

Need help to configure the Application logs in Azure storage, the below Sitecore Environment. Version: Sitecore 9.3 Azure PaaS Monitoring: New Relic. Application logs are currently available in the ...
1 vote
2 answers
35 views

Sitecore forms required validation is not working for dropdownlist

We have upgraded to Sitecore 10.1 from Sitecore 8.7. In Sitecore forms, dropdownlist required validation is not working. The required validation is working for all simple type fields but not for ...
1 vote
2 answers
37 views

Does disabling Sitecore XDB and Tracking help in improving Site Performance?

Can disabling Sitecore XDB and tracking help in improving Site Performance ? What all can be functionalities/ features can be impacted if we disable them ?
1 vote
2 answers
41 views

Issue in setup Sitecore Publishing Module (ver 4.3) on local system (Error: An error occurred while starting the application)

I am trying to setup publishing module (ver 4.3) for my sitecore 10.0 application, everything has been done based on manual/script steps in document. Like configure connection string, creating IIS ...

15 30 50 per page
1
2 3 4 5
232