1

I'm trying to setup a Sitecore 9.0 update 1 installation on my local machine using

  • windows 10
  • Solr 6.6.2
  • SQL Server 2016 SP1 Sql Express 2017
  • SIF-less 0.6.0.0

Despite a couple of annoying hickups I managed to get as far as past Solr installation, service restart, certificates setup.

The installation fails with the following output:

    PS>TerminatingError(Invoke-CommandTask): "The running command stopped because the preference variable 
    "ErrorActionPreference" or common parameter is set to Stop: Command 
    C:\inetpub\wwwroot\xxxx.xconnect\App_Data\collectiondeployment\Sitecore.Xdb.Collection.Database.SqlShardingDeploymentTool.exe 
    returned a non-zero exit code - (-1073741811)"

Its obviously the "SqlShardingDeploymentTool" that complains during installation, but I'm having a hard time finding out why.

The SIF-less test execution returns all green.

Output from SIF-less test execution

1

Sql Server 2017 is not supported, you need to have Sql Server 2016 Update 1.

Please have a look on Prerequisites and Requirements at https://dev.sitecore.net/~/media/1E934A0DB5534F2CB1D98A0F4000B25C.ashx

enter image description here

  • Tried with Sql server 2016 SP1 after your message (the company has such an instance already, so I just changed connection settings in SIF-less), but to no avail. The same error occurred. – VilladsR Feb 12 '18 at 11:22
  • I updated the question to be specific to the supported database server. – VilladsR Feb 12 '18 at 11:24
  • Are you sure Sifless is working with Sitecore 9.0.1 ? – Vlad Iobagiu Feb 12 '18 at 11:36
  • flux-digital.com/blog/… claims that it works. – VilladsR Feb 12 '18 at 11:45
  • Is it using Sif not Sifless on your link – Vlad Iobagiu Feb 12 '18 at 12:13
1

First of - I didn't fix the error, I simply avoided it by not utilizing xconnect.

This was done by not filling out the two following fields in the SIF-less application:

  • XConnect Package
  • xConnect Name

Removing these fields allows the install script to complete successfully (leaving you with the Sitecore default site, which was my actual goal).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.