I have added SXA (v1.6) OOTB box carousel component and added some slides. After publishing the page, it is adding slide number as query string parameters"/Home?carousel=0" on the browser's URL.

and the numbers are changing whenever the slide changes.

Please provide me the pointers to resolve this issue.

In previous version of the SXA (1.5 and below), this is not happening.

  • 1
    It's not a bug - it's a feature. Where do you see an issue here? Commented Feb 16, 2018 at 7:35
  • In Sitecore 8.2 with sxa, its not appending the query string parameter, but in SC9-SXA its happening. Is there any way to stop this?
    – Amit Kumar
    Commented Feb 16, 2018 at 15:36
  • What version of the platform and SXA are you using? Commented Feb 16, 2018 at 17:21
  • Sitecore 9.0.1 rev. 171219 SXA 1.6 rev 180103
    – Amit Kumar
    Commented Feb 17, 2018 at 5:58

1 Answer 1


Unfortunately, the latest SXA v1.6 has this as a new "feature" to support the browser's history and direct linking to the carousel slides. It is tightly associated with the "bullet navs". To remove this, you have 2 options:

Option A. Remove the "bullet navs". Edit the carousel component and select None for the Navigation Type. Save and publish the page.

Option B. Update the theme's carousel JS file. Use Creative Exchange Live and export the page that has the carousel. Edit the carousel component JS which is located at:


Comment the line (line 344):

updateQueryParam(componentRoot.attr('id') || "carousel", index);

Save it and publish the theme.

  • Thanks for the solution. I will verify and let you know.
    – Amit Kumar
    Commented Feb 18, 2018 at 8:30
  • I wouldn't suggestion second option. Please remember that all SXA items which you will modify will be overridden while upgrading SXA to the latest version. You will lose all your modifications. Commented Feb 18, 2018 at 21:42
  • David, I wouldn't recommend changing the original either but you can make a copy of the theme and update that instead.
    – Marco
    Commented Feb 19, 2018 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.