I'm trying to install Sitecore 9 Update 1 XP0 topology and everything looks great until the step

CreateShardApplicationDatabaseServerLoginSqlCmd

enter image description here

The server I am running the installation was already used to install XP1 topology, and everything worked just fine.

Any idea what might be the issue?

up vote 7 down vote accepted

Right after post my question, realized that sqlcmd was not installed at the server - which is weird, because XP1 topology didn't require at all!

In my case, I had to download and install

Once I got both installed, it was just a matter to re-run the XP0.

  • 2
    Unfortunately this was missed off the docs for update 1. We're aiming to have this corrected soon. – Kieranties Feb 16 at 11:57

Thank you, Vinicius. To add to the correct answer, after downloading the two utilities from your answer, my problem was not resolved.

I encountered into the same issue when running Sitecore installation using SIF on staging environment where SQL server was not added to environment variables. When running the SIF on dev/staging/prod environments where SQL server management studio is not installed, after installing the 2 utilities, we need to make sure that environment System variable Path should contain C:\Program Files\Microsoft SQL Server\110\Tools\Binn which is a location of "SQLCMD.EXE"

enter image description here

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.