In a project, I have used Lucene Search. Earlier everything was working fine. But from last few days I am facing issue in getting items through search on production server.

I performed Index Rebuild many times. All items are present in the content tree. But they are not displaying on the site.

My assumption is: there must be some number of items limit upto which Lucene supports indexing.

Please guide me if someone has faced similar issue earlier.

  • 1
    Lucene has no item limit. Only until your hard drive runs out of space.
    – Chris Auer
    Commented Feb 18, 2018 at 2:38
  • Do you have a CD and CM server. Or is everything on one server?
    – Chris Auer
    Commented Feb 18, 2018 at 2:39
  • Yes we have CM and CD servers. Commented Feb 18, 2018 at 6:29
  • Currently I don't ave access of CD server. So should I check hard drive space on server? Commented Feb 18, 2018 at 6:34
  • 1
    You need to resolve this issue on the CD servers, not anywhere else.
    – Mark Cassidy
    Commented Feb 18, 2018 at 9:45

3 Answers 3



I think your answer is going to be in the indexing strategy that is configured on the CD server. If you check the config (http://prod/sitecore/admin/showconfig.aspx) on your CD server. Check to see what strategy your index is running. I run the strategy onPublishEndAsync for my web database on my CD servers.

<strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/onPublishEndAsync"/>

This is what the strategy looks like in your index config. enter image description here

Event Queue enabled

You will also need to make sure that Event Queue is enabled on your CD server. You can check that by looking for the setting EnableEventQueues is set to true.

<setting name="EnableEventQueues" value="true"/>

Once this is complete, when a publish is completed on the CM server, an index will be initiated on the CD server(s).


There is no such kind of Item indexing limit in Lucene, Could you please follow some checks immediately after re-indexing? Before that Make sure only one configuration should be enable for your environment, either Lucene or Solr. As you are using Lucene then make sure that all the Solr search related configs should be disabled.

  1. Check the Crawling.log file and Search.log file.
  2. Check the Include and Exclude template section in Sitecore.ContentSearch.Lucene.DefaultIndexConfiguration.config, by default the Exclude Template should have bucket folder template in list and Include Template section should be commented.
  3. Check whether index files are getting updated or not after re-indexing.

There are certain analysis you need to do to debug the issue

  • Check if the index was created. Start with rebuilding the Index.
  • Check the http://prod/sitecore/admin/showconfig.aspx to verify if the configuration of your index is present
  • By default Sitecore.Search.Crawlers.DatabaseCrawler uses lowercase names for document fields names so remember to use __created instead of __Created, etc. If you still have any doubts, use Luke(http://code.google.com/p/luke/) to see what exactly is indexed.
  • The templates that should be indexed missing. Look for the "list:IncludeTemplate" as shown below in the config and the guid if they are present in Sitecore.

    <include hint="list:IncludeTemplate">    

You can look for the details to resolve this in the blog- https://www.cognifide.com/our-blogs/sitecore/troubleshooting-sitecore-lucene-search-and-indexing/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.