0

I am trying to create an EXM campaign. Somehow, I can send a test e-mail but it always fail, when I try to send it to a list of recipients.

What I did:
1- Create a new list by uploading a CSV file (successful but list is only available in English version)
2- Create my email campaign
3- Assign the list to my email campaign.

Expected result: No error message should be shown and EXM is able to retrieve and process the list

Actual result:

[ArgumentNullException: Value cannot be null. Parameter name: list]   
  Sitecore.Diagnostics.Assert.ArgumentNotNull(Object argument, String argumentName) +63
  Sitecore.ListManagement.ListManager`2.GetContacts(TContactList list) +39
  Sitecore.Modules.EmailCampaign.RecipientManager.GetMessageRecipients() +119
  Sitecore.Modules.EmailCampaign.RecipientManager.GetTargetRecipientCount() +14
  Sitecore.Modules.EmailCampaign.Core.MessageStateInfo.get_NumSubscribers() +49
  Sitecore.Modules.EmailCampaign.Core.MessageInfo.get_To() +77
  Sitecore.EmailCampaign.Cm.sitecore_modules.Shell.EmailCampaign.UI.Editors.MessagePreviewPage.FillMessageHeader(MessageInfo info) +266
  Sitecore.EmailCampaign.Cm.sitecore_modules.Shell.EmailCampaign.UI.Editors.MessagePreviewPage.FillPreviewSection() +254
  System.Web.UI.Control.LoadRecursive() +154
  System.Web.UI.Control.LoadRecursive() +251   
  System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4088

Additional information:
I am using this patch Sitecore.Support.162905-8.2.3.0.zip

Question:
I am pretty sure that either I am doing something wrong or forgot to configure something, can somebody help?

  • 1
    Which version of EXM and Sitecore you have installed? – Peter Procházka Feb 23 '18 at 11:38
1

Edit to my below answer:

I found this link in the Sitecore knowledgebase. This might be an answer to the nagging issue.

Please feel free to refer the below answer though:


We have been through a similar issue and I actually have a post here that hopefully will help you get a bit further. As far as I have heard, this is a known issue within Sitecore v8.2.

0

There are some potential solutions in your case:

1) Check if the Global Opt-out List is selected. Navigate to the current EXM Manager Root item and check if Global Opt-out List is chosen.

2) Could you make sure that you selected an Exclude lists for the newly created email campaign as well as the Include lists

3) Navigate to the contact list that you uploaded based on the CSV file and make sure that it isn't being indexed and locked. (warnings will be there if it is)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.