22

Let me start by saying that I have had this happen before and typically I have only had to reindex the Master index. However, nothing is working to display the 15 forms that we have created. I have already been through this post here:

Why I can't see my forms/templates in the Sitecore Forms application?

I can modify the forms through the Content Tree at this point, but I drastically need the UI in order to see where things are placed to make quick changes.

Can anyone help?

If this goes over 24-48 hours, I am going to take to Sitecore Support and log a ticket. Thanks in advance!

  • Which version you use 9.0 or 9.0.1 precisely? Can you update your question with screenshot what you can see when you open Forms? Is browser Dev toolbar showing you some errors during load? – Peter Procházka Mar 1 '18 at 19:20
  • I am using Version 9. O. There's no real screenshot to show other than it just says no forms to display. If I look at the console in the browser the only thing it is saying that it is not loading is opensans.css. Everything else is fine – Toby Gutierrez Mar 1 '18 at 19:34
  • Could you check if you have errors in Solr log. I’ve had the same issue when Solr was not be able to create core for xConnect. – Artsem Prashkovich Mar 1 '18 at 21:29
  • There is only warning regarding [segments] as seen in the other post. No "ERROR" messages at all. – Toby Gutierrez Mar 1 '18 at 21:31
  • I have had this same issue, just haven't had time to troubleshoot it... – LonghornTaco Mar 1 '18 at 21:53
9

Here is the answer my Sitecore community. Thanks to Sitecore Support!

Wrong Forms folder ID. Somewhere along the check-in source control travels someone must have deleted the original Forms folder, and then created a new Forms folder with a different ID. Because of this one simple change by a developer the Forms Designer was now rendered useless and ineffective.

The solution to this issue is this:

  • Do NOT delete the Forms folder and create a new one if you don’t need to!
  • If you do delete the Forms folder, get it from another instance of Sitecore 9.
  • If for some reason you want to run with a Forms folder with a different ID then you must change to this ID for your new Forms folder in the Root field of these items below in the Core database: SearchConfig: {60F35FD9-88CB-4DF5-8E78-1E9BF5FE181C} AllFormsSearchConfig: {A7C51A03-028A-4414-98DF-116DFAEAE5A6}

My recommendation is to NOT opt for #3 as this will get away from you, and your client down the road unless you document it, keep for future reference, and refer to for future upgrades. Ain’t nobody got time for that! Just opt to get on Slack and ask someone for the OOTB Forms folder item in a package, move all your forms into the correct OOTB Forms folder and you are all set.

https://sitecoresandbox.com/2018/03/09/there-are-no-forms-to-display-in-sitecore-9-forms-designer/

| improve this answer | |
4

After clean installation of 9.1.1, I have the same issue. I did reindex. I checked IDs. But I suppose issue is somewhere else. This is from search log:

35448 16:58:48 ERROR Solr Error : ["undefined field is_template"] - Query attempted: [(((((_content:(**) OR _name:(**) OR _displayname:(**)) AND (is_template:(1) AND _latestversion:(1))) AND _path:(b701850acb8a4943b2bcdddb1238c103)) AND _templatename:(Form)) AND (-__hidden:(1)  *:*))]

Quick solution is to define "is_template" field from "istemplate" field:

<field fieldName="istemplate" returnType="bool">Sitecore.ContentSearch.ComputedFields.IsTemplate,Sitecore.ContentSearch</field>
<field fieldName="is_template" returnType="bool">Sitecore.ContentSearch.ComputedFields.IsTemplate,Sitecore.ContentSearch</field>

in default index configuration

| improve this answer | |
3

I have the same issue for sitecore 9.1.0 azure paas, because in azure search we have field limitation i set up indexAllFields to false, so need to add "Is Template" filed to index:

<include hint="list:AddIncludedField">
   <fieldId>{558F9307-EBAF-480D-88B5-DFE9E63A66DE}</fieldId>
</include>

enter image description here

Updated 6/20/2019

Also need to add ishidden field:

<fieldId>{39C4902E-9960-4469-AEEF-E878E9C8218F}</fieldId>
| improve this answer | |
  • "add" = "Check" – Blue Clouds Jul 24 '19 at 8:46
  • No, not "check". They are referring to the XML configuration, not the Sitecore CE UI. – haliphax Aug 3 at 14:27
1

I'm adding this answer as well in case you are not in the situation that the marked answer suggests. Another thing to check is your indexes. The forms on the Sitecore Forms page are queried from the search index, not the content tree, and therefore, if your indexes are not populated with those forms, they won't show up. Please refer to this blog post for more information: https://citizensitecore.com/2017/11/19/sitecore-9-forms-form-doesnt-show-up-after-creation/

Rebuilding your master index is the way to resolve that issue (or highlight the forms folder and use the "Reindex Tree" option in the developer toolbar of the content editor).

| improve this answer | |
0

In my case, it was an issue with my system templates. Due to some unknown mess-up, none of the /system templates (including the Forms template) had an English version. This threw exceptions when building a query:

 at Sitecore.ContentSearch.Utilities.LanguageFallbackDataService.EnsureFallbackVersion(Item rootItem)
   at Sitecore.ContentSearch.Utilities.LanguageFallbackDataService.GetDescendantsByTemplateWithFallback(Item rootItem, TemplateID templateId)
   at Sitecore.ContentSearch.Utilities.LanguageFallbackDataService.GetDescendantsByTemplateWithFallback(Item rootItem, String templateId)
   at Sitecore.ContentSearch.Utilities.QueryBuilder.CreateQuery[T](IProviderSearchContext context, IEnumerable`1 searchStringModel, Item startLocationItem, IEnumerable`1 additionalContexts)
   at Sitecore.ContentSearch.Utilities.QueryBuilder.CreateQuery[T](IProviderSearchContext context, IEnumerable`1 searchStringModel)
   at Sitecore.ItemWebApi.Pipelines.Search.ParseSearchText.Parse(IProviderSearchContext providerSearchContext, String searchText)
   at Sitecore.ItemWebApi.Pipelines.Search.ParseSearchText.Process(SearchArgs args)
   at (Object , Object )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
   at Sitecore.ItemWebApi.Pipelines.Request.Search.RunSearchPipeline(RequestArgs args, String searchText, String languageName, Boolean showHiddenItems)
   at Sitecore.ItemWebApi.Pipelines.Request.Search.Process(RequestArgs args)

Other than this, I've also noticed that I don't see any forms when I've previously set the database to 'core' in the content editor.

| improve this answer | |
0

Content language issue can be a problem. unknown field 'heading_t_pl' (poland) is what I got in error logs. It could be any language...

  • '*t_cs'
  • '*_pl'(poland)
  • '*_cz'(czech)

A solution for language addition is given here.

As @bushland25 pointed out, The forms on the Sitecore Forms page are queried from the search index, not the content tree.

So in my case, I went specifically to that content item(form) and did "Reindex Tree" option in the developer toolbar of the content editor. UK contents worked, but other countries gave error on the content editor(when I did re-indextree).

| improve this answer | |
-1

Go to the Control panel and below there will be INDEXING, Click the Indexing manager and Rebuild all the indexes

| improve this answer | |
  • Welcome to SSE community Shareef. I am down voting your answer as the answer above from @bushland25 already talks about index rebuilding in detail. Please update your answer if you want to suggest another approach to resolve the issue. Or once you have sufficient reputation, you will be able to post it as a comment. – Amitabh Vyas Feb 27 '19 at 14:16
  • just to correct it - Do Index rebuild but only for master and core issue will be resolved. @AmitabhVyas I can see there is no above comment/answer who mentioned to rebuild master+core index if no forms are appearing on the form dashboard. Please correct me if i missed something. – Pradeep Gupta Sep 8 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.