Can somebody help me to resolve this error which I am getting when deploying the same ReactBasicApp using sitecore jss

[InstallationException]: Could not find JSS app configuration for 'my-first-jss-app'. Ensure you have included or previously installed a configuration patch for the app. at Sitecore.Update.Installer.Items.CustomActionInstaller.Process(IProcessingContext entry, IProcessingContext context) at Sitecore.Update.Installer.DiffInstaller.ExecutePostInstallationInstructions(String packagePath, String historyPath, InstallMode mode, MetadataView view, ILog installationProcessLogger, List`1& entries) at Sitecore.Ship.Infrastructure.Update.UpdatePackageRunner.Execute(String packagePath, Boolean disableIndexing) at Sitecore.Ship.AspNet.Package.InstallUploadPackageCommand.HandleRequest(HttpContextBase context) at Sitecore.Ship.AspNet.Package.InstallPackageCommand.HandleRequest(HttpContextBase context) at Sitecore.Ship.AspNet.AboutCommand.HandleRequest(HttpContextBase context) at Sitecore.Ship.AspNet.BaseHttpHandler.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Thanks & Regards

Jag

Did you run jss deploy config? You can manually copy the config that brings JSS app registration to your Sitecore instance. https://jss.sitecore.net/#/setup/sitecore-config?id=step-3-config-deployment

after running npm run deploy-conifg set your connection config for sitecore instance while making sure you have put the correct configs.

You can follow this article for details.

http://www.flux-digital.com/blog/getting-started-sitecore-jss/

Also you can take help for Sitecore.Ship.AspNet.Package.InstallUploadPackageCommand.GetRequest(System.Web.HttpRequestBase)

https://www.csharpcodi.com/vs2/2801/Sitecore.Ship/src/Sitecore.Ship.AspNet/Package/InstallUploadPackageCommand.cs/

  • Just a note that my blog link above is for Tech Preview 1 so for Tech Preview 2 you should use: 'jss deploy config' as mentioned by Alex. – Adam Seabridge Apr 3 at 10:41

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.