I'm trying to install Sitecore Commerce 9 on my local machine. To do that I've created "C:\deploy" and copied files into that.



Then revised SIF installation file like below:

    #Requires -Version 3
    [string]$SiteName = "ConnectSite",  
    [string]$SiteHostHeaderName = "sxa.storefront.local",   
    [string]$SqlDbPrefix = $SiteName,
    [string]$CommerceSearchProvider = "SOLR"

$global:DEPLOYMENT_DIRECTORY = Split-Path $MyInvocation.MyCommand.Path
$modulesPath = ( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "Modules" )
if ($env:PSModulePath -notlike "*$modulesPath*") {
    $p = $env:PSModulePath + ";" + $modulesPath
    [Environment]::SetEnvironmentVariable("PSModulePath", $p)

$params = @{
    Path                               = Resolve-Path '.\Configuration\Commerce\Master_SingleServer.json'   
    SiteName                           = $SiteName
    SiteHostHeaderName                 = $SiteHostHeaderName 
    InstallDir                         = "$($Env:SYSTEMDRIVE)\inetpub\wwwroot\$SiteName"
    XConnectInstallDir                 = "$($Env:SYSTEMDRIVE)\inetpub\wwwroot\$($SiteName)_xconnect"
    CertificateName                    = $SiteName
    CommerceServicesDbServer           = $($Env:COMPUTERNAME)
    CommerceServicesDbName             = "SitecoreCommerce9_SharedEnvironments"
    CommerceServicesGlobalDbName       = "SitecoreCommerce9_Global"     
    SitecoreDbServer                   = $($Env:COMPUTERNAME)
    SitecoreCoreDbName                 = "$($SqlDbPrefix)_Core"
    CommerceSearchProvider             = $CommerceSearchProvider
    SolrUrl                            = "https://localhost:8983/solr"
    SolrRoot                           = "D:\Sitecore\solr-6.6.2\solr-6.6.2"
    SolrService                        = "solr622"
    SolrSchemas                        = ( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "SolrSchemas" )
    SearchIndexPrefix                  = ""
    AzureSearchServiceName             = ""
    AzureSearchAdminKey                = ""
    AzureSearchQueryKey                = ""
    CommerceEngineDacPac               = Resolve-Path -Path "C:\deploy\Assets\Sitecore.Commerce.Engine.DB.dacpac"      
    CommerceOpsServicesPort            = "5015"
    CommerceShopsServicesPort          = "5005"
    CommerceAuthoringServicesPort      = "5000"
    CommerceMinionsServicesPort        = "5010"     
    SitecoreCommerceEngineZipPath      = Resolve-Path -Path "C:\deploy\Sitecore.Commerce.Engine.SDK.2.0.1922"       
    SitecoreBizFxServicesContentPath   = Resolve-Path -Path "C:\deploy\Sitecore.BizFX.1.0.572"      
    SitecoreIdentityServerZipPath      = Resolve-Path -Path "C:\deploy\Sitecore.IdentityServer.1.0.65.zip"
    CommerceEngineCertificatePath      = Resolve-Path -Path "C:\deploy\Sitecore.cer"        
    SiteUtilitiesSrc                   = ( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "SiteUtilityPages" )    
    HabitatImagesModuleFullPath        = Resolve-Path -Path "C:\deploy\Sitecore.Commerce.Habitat.Images-1.0.0.zip"  
    AdvImagesModuleFullPath            = Resolve-Path -Path "C:\deploy\Adventure Works Images.zip"  
    CommerceConnectModuleFullPath      = Resolve-Path -Path "C:\deploy\Sitecore Commerce Connect Core 11.0.192.zip" 
    CEConnectPackageFullPath           = Resolve-Path -Path "C:\deploy\Sitecore.Commerce.Engine.Connect.2.0.835.update"
    PowerShellExtensionsModuleFullPath = Resolve-Path -Path "C:\deploy\Assets\Sitecore PowerShell Extensions-4.7.2 for Sitecore 8.zip"
    SXAModuleFullPath                  = Resolve-Path -Path "C:\deploy\Assets\Sitecore Experience Accelerator 1.6 rev. 180103 for 9.0.zip"
    SXACommerceModuleFullPath          = Resolve-Path -Path "C:\deploy\Sitecore Commerce Experience Accelerator 1.0.2184.zip"
    SXAStorefrontModuleFullPath        = Resolve-Path -Path "C:\deploy\Sitecore Commerce Experience Accelerator Storefront 1.0.2184.zip"
    SXAStorefrontThemeModuleFullPath   = Resolve-Path -Path "C:\deploy\Sitecore Commerce Experience Accelerator Storefront Themes 1.0.2184.zip"
    SXAStorefrontCatalogModuleFullPath = Resolve-Path -Path "C:\deploy\Sitecore Commerce Experience Accelerator Habitat Catalog 1.0.2184.zip"
    MergeToolFullPath                  = Resolve-Path -Path "C:\deploy\Assets\Microsoft.Web.XmlTransform.dll"
    UserAccount                        = @{
        Domain   = $Env:COMPUTERNAME
        UserName = 'CSFndRuntimeUser'
        Password = 'Pu8azaCr'
    BraintreeAccount                   = @{
        MerchantId = ''
        PublicKey  = ''
        PrivateKey = ''
    SitecoreIdentityServerName         = "SitecoreIdentityServer"

if ($CommerceSearchProvider -eq "SOLR") {
    Install-SitecoreConfiguration @params
elseif ($CommerceSearchProvider -eq "AZURE") {
    Install-SitecoreConfiguration @params -Skip InstallSolrCores

However, after running "Deploy-Sitecore-Commerce.ps1" in Admin mode, I'm getting below error:

Windows PowerShell transcript start
Start time: 20180313130237
Username: AFSHIN-DELL\Afshin
RunAs User: AFSHIN-DELL\Afshin
Configuration Name: 
Machine: AFSHIN-DELL (Microsoft Windows NT 10.0.16299.0)
Host Application: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe
Process ID: 1896
PSVersion: 5.1.16299.248
PSEdition: Desktop
PSCompatibleVersions: 1.0, 2.0, 3.0, 4.0, 5.0, 5.1.16299.248
BuildVersion: 10.0.16299.248
CLRVersion: 4.0.30319.42000
WSManStackVersion: 3.0
PSRemotingProtocolVersion: 2.3
Transcript started, output file is C:\deploy\SIF.Sitecore.Commerce.1.0.1748\SXAStorefront.CreateBinding.180313.log
                                                      Sitecore Install Framework
                                                           Version - 1.1.0

WorkingDirectory  : C:\deploy\SIF.Sitecore.Commerce.1.0.1748
LogPath           : C:\deploy\SIF.Sitecore.Commerce.1.0.1748\SXAStorefront.CreateBinding.180313.log
WhatIf            : False
Verbose           : SilentlyContinue
Configuration     : C:\deploy\SIF.Sitecore.Commerce.1.0.1748\Configuration\Commerce\SXAStorefront\SXAStorefront.CreateBinding.json
Debug             : SilentlyContinue
WarningAction     : Continue
ErrorAction       : Stop
InformationAction : Continue

[---------------------------------------------------- CreatePaths : EnsurePath -----------------------------------------------------]
[CreatePaths]:[Create] c:\certificates

[----------------------------------------------- CreateSignedCert : NewSignedCertificate -------------------------------------------]

FileInfo                        Certificate
--------                        -----------
C:\certificates\ConnectSite.crt [Subject]...

[---------------------------------------------------- StopWebsite : ManageWebsite --------------------------------------------------]
[StopWebsite]:[Stop] ConnectSite
Command start time: 20180313130239
PS>TerminatingError(Get-WebItemState): "Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist."
>> TerminatingError(Get-WebItemState): "Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist."
>> TerminatingError(Get-WebItemState): "Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist."
>> TerminatingError(Invoke-ManageWebsiteTask): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist."
>> TerminatingError(Invoke-ManageWebsiteTask): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist."
Install-SitecoreConfiguration : Cannot find path 'IIS:\Sites\ConnectSite' because it does not exist.
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\1.1.0\Public\Install-SitecoreConfiguration.ps1:253 char:21
+                     & $entry.Task.Command @paramSet | Out-Default
+                     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:02
Windows PowerShell transcript end
End time: 20180313130239

Can anyone please kindly help me to get rid of that error please?

  • did you installed a clean Sitecore 9.0.1 solution before you start installing commerce ? Mar 13 '18 at 3:49

From the screenshot provided it is evident that you haven't installed Sitecore 9 before installing Sitecore Experience Commerce 9 (Sitecore XC 9) that's why 'ConnectSite' cannot be found.

Please follow my blog post with step by step guide how to install Sitecore XC 9:


If you have trouble installing Sitecore 9, follow my blog series with also step by step guidelines how to do that:


It will show you how to prepare environment with all prerequisites, then how to install and configure SOLR to run on SSL and last part is finally installing Sitecore instance using Sitecore Installation Framework (SIF).

Use latest version of SIF - 1.2.

  • bbc.local website is sitecore 9 instance. problem solved by changing powershell script. thanks anyway
    – Afshin
    Mar 14 '18 at 7:30

Before installing Sitecore Commerce you need to read this document very carefully http://commercesdn.sitecore.net/SitecoreXC_9.0/Installation-Guide/Sitecore-XC-9.0_Installation_Guide(On-Prem).pdf

The first line on page 8 in above pdf is-

The instructions in this document assumes that you have already installed the Sitecore XP 9.0 software on your system, as described in the Sitecore Experience Platform Installation Guide.

so please refer this document and one more thing please update the parameter's value in the PowerShell script with your local environment values(refer page 13, 14, 15 for more details)

In your case "ConnectSite" is the name for the Sitecore 9 site name and it should exist before running the commerce setup script.

  • Sitecore 9 and SXA have already installed. I just updated powershell scripts and problem solved
    – Afshin
    Mar 14 '18 at 7:29

I'm quite sure that you have changed the website name of the IIS website of your content management or standalone instance to 'bbc.local' and forgot to reflect that change on the SiteName parameter in the SIF script.

In Master_SingleServer.json line 240 you can see task 'CreateBinding' where SIF passes the SiteName parameter to SXAStorefront.CreateBinding.json.

"CreateBinding": {
  "Type": "InstallSitecoreConfiguration",
  "Params": {
    "Path": ".\\Configuration\\Commerce\\SXAStorefront\\SXAStorefront.CreateBinding.json",
    "SiteName": "[parameter('SiteName')]",
    "CertificateName": "[parameter('CertificateName')]",
    "StorefrontHostName": "[parameter('SiteHostHeaderName')]"

And in 'Commerce\SXAStorefront\SXAStorefront.CreateBinding.json' you can see, that SIF is trying to stop an IIS website using exactly this name.

"StopWebsite": {
  // Stops the website if it is running.
  "Type": "ManageWebsite",
  "Params": {
    "Name": "[parameter('SiteName')]",
    "Action": "Stop"

So, since there is no preferred error action override, the script stops if the website cannot be found.

I think you just need to update the $SiteName default value to match your environment.

#Requires -Version 3
    [string]$SiteName = "ConnectSite",  
    [string]$SiteHostHeaderName = "sxa.storefront.local",   
    [string]$SqlDbPrefix = $SiteName,
    [string]$CommerceSearchProvider = "SOLR"

My general advice when you're using SIF for On-Premise installations:

Be sure to customize the SIF installation scripts to match YOUR PARTICULAR environment. You should not use out-of-the-box SIF configurations for productive installations. copy them as a basis, then customize them to your needs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.