Am attempting to upgrade from SC 8 Update 5 to SC 9 Initial Version using the Sitecore Express Migration Tool.

These are the problems I am facing, and am wondering if anyone is facing something similar.

  • Using Express Tool 3.0

It prevents me from going to next screen from 'Instance parameters' screen. The parameters used are not long at all, and exactly the same ones to the one I used for Express Tool 3.1. Here is what the log captured:

enter image description here

  • Using Express Tool 3.1

It doesn't allow me to select any items at all. enter image description here


  • I've seen the error you are seeing before when trying to serialize a tree structure that was too deep or had too long names (total path length was too long). Could that be the case?
    – Gatogordo
    Mar 14, 2018 at 10:00
  • @Gatogordo Good point. High chance. How did you work around this issue btw? Thanks Mar 14, 2018 at 10:06
  • You could check this setting: "Serialization.SerializationFolderPathMaxLength" Not sure anymore whether you need to lower or raise the value..
    – Gatogordo
    Mar 14, 2018 at 10:14
  • @Gatogordo Tried directly editing web.config and value seems to be replaced. Tried patching the value through Include patch file, but seem to be no effect. Were you on 3.0 / 3,1 too? Mar 14, 2018 at 10:28
  • As mentioned we were just serializing so the scenario was different. I think this is the right track, but you might need Sitecore support for an actual fix or workaround.
    – Gatogordo
    Mar 14, 2018 at 10:32

2 Answers 2


@codeandfootball I ran into the same issue while running the Sitecore Express Migration Tool 3.1 and realised that the error is misleading and not actually referring to the path\connection strings in the instance parameters but rather the path that the Migration Tool is running from.

In my case I had the Migration Tool extracted onto my desktop within a nested folder which caused it to run into the max length error. Moving the folder to the the root drive solved this issue for me.

  • Hi, yes. Forgot to update my answer on this question. Yes Sitecore support replied saying filename was too long. Thanks Jun 15, 2018 at 5:47

Sitecore support replied saying it was an error due to overly long filepaths. There should be a maximum of 260 chars only. I reduced the filepath, and it eventually worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.