1

How do I enable or show the "Edit Item" button for a rendering?

I see this when looking at example Habitat Project (8.x version), but I don't see on my Sitecore 9 implementation.

enter image description here

2

This is a custom button made and enabled for Habitat as a showcase. You can find it under FieldEditor Foundation module -> https://github.com/Sitecore/Habitat/blob/master/src/Foundation/FieldEditor/serialization/WebEdit.FieldEditorAll/Edit%20Item.yml

Here is link for Sitecore 9 branch -> https://github.com/Sitecore/Habitat/blob/feature/v9/src/Foundation/FieldEditor/serialization/WebEdit.FieldEditorAll/Edit%20Item.yml

| improve this answer | |
0

Please follow the below steps

  1. Login into Sitecore Content Editor.
  2. Select the database as "Core"
  3. Go to the item '/sitecore/content/Applications/WebEdit/Default Rendering Buttons/Options'
  4. Assign Security Rights on the "Options" as Read and Write
| improve this answer | |
  • I gave that a go, but doesn't seem to have worked.. Did I need to assign the rights to a specific role? I'm logged in as the administrator currently. – mp3duck Mar 16 '18 at 10:03
  • yes it should be with the role you are trying to edit. In this case Sitecore/Admin – Amitabh Mar 16 '18 at 10:07
  • Comparing items in the Default Rendering Buttons list between my site, and habitat, I can see habitat has an extra option for "Edit Item".. I'll see if I can add same one in my application – mp3duck Mar 16 '18 at 10:07
  • Seems this is a custom button in Habitat, and not an out of the box option.. – mp3duck Mar 16 '18 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.