10

I noticed that the Sitecore Log Analyzer on market place does not say anything about the latest Sitecore versions and whether it is supported or not. I have used it on 8 and it was working fine but haven't tried on versions 8.1 and 8.2. Do you know if this module is supported on the latest Sitecore releases?

15

The underlying logging framework that Sitecore uses is Apache Log4Net, and this has not changed for a very long time (since early 6.x). Even the version used is the same, 1.2.11 I believe.

The pattern used for logging messages is also exactly the same between the versions:

<layout type="log4net.Layout.PatternLayout">
  <conversionPattern value="%4t %d{ABSOLUTE} %-5p %m%n" />
</layout>

The Log Analyser tools relies on a certain pattern being used in the log4net log files. Since the underlying framework and the pattern have not changed it will work with the latest versions of Sitecore without any issues.

5

I don't think that it make any difference which Sitecore version you are using. It just analyze logs (which are simply .txt files).

I am constantly using it on 8.1 and 8.2. No problems found. I suppose authors forgot to update Requirements section.

  • That's what I'm thinking as well. I'll leave this open for now to see what other users have to say – Diego Oct 11 '16 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.