0

I have a some instances running on Sitecore 8.1 .I want to upgrade these instances to Sitecore 9.1.

I know that I should use MS-SQL-2016 to support XDB. I want to install Sitecore-9.1 directly and use the old SQL data.

My question is : For Sitecore 8.1's SQL data . Do I need use some tool or scripts to migrating these data . Or just do a backup and restore into MS-SQL-2016?

5
  • Don't forget to use MS SQL 2016 SP1 as only that release is compatible -> kb.sitecore.net/articles/087164 Mar 22 '18 at 7:57
  • @VladIobagiu I had saw this question , what I want to know is not version problem but how to migrate data
    – Guang Chen
    Mar 22 '18 at 8:05
  • docs.microsoft.com/en-us/sql/t-sql/statements/… you can see here sql 2016 supports sql 2014 data Mar 22 '18 at 8:10
  • @VladIobagiu thanks for replying . Does sitecore9's sql schemas are same as the sitecore8 ? so that what need to do is do a backup at SQL 2014 and restore at SQL 2016. I want to install Sitecore-9.1 directly and use the old SQL data.
    – Guang Chen
    Mar 22 '18 at 8:18
  • I don't think is the same schema. Mar 22 '18 at 8:25
0

You do need to update your solution. You cannot just get a newer version of Sitecore and expect it to work with your old databases.

For an 8.1 solution, you can upgrade in 1 step.

Depending on what you have in the database you could also be able to migrate your data (with Razl, packages, ...) into a clean Sitecore 9. If you only have "content" that might be an option.

Also don't forget you probably will have to change some of your code..

1
  • thanks for replying . Do you mean : first use SIF to install a a clean Sitecore 9 . and use Razl (what is packages , sitecore9 upgrade packages?) migrate data ?
    – Guang Chen
    Mar 22 '18 at 8:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.