3

I installed Sitecore 9 on my local machine having CM and CD together and Solr and xConnect are working fine. However, there is no data in all xMarketing features (such as Experience Analytics, profile, forms, device detection so on).

I enabled DEBUG mode for Analytics and created simple Form page. Here is the log file:

18052 16:28:26 INFO xDB is enabled.
18052 16:28:26 INFO Tracking is enabled.
18052 16:28:26 INFO Valid xDB license is present.
DEBUG ContactManager.LoadContact(75cf53ec-80d5-406d-a605-1e9e5a49c7ce) - contact is loaded, storing it in shared session
DEBUG Min threads: 4, Active threads: 1.
INFO Cache created: 'referenceDataDefinitionTypeCache' (max size: 1MB, running total: 2756MB)
DEBUG [Analytics]: Start tracking: http://xp0.sc/form test
....
DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated
DEBUG Tracker is not initialized. ReleaseContact processor is skipped

I added @Html.Sitecore().VisitorIdentification() and Active server roles set standalone. Also, rebuilt Reporting database.

Do you have any idea where I need to check?

============ Update 1 ============

I can see new contact information in MyLocal_Xdb.Collection.Shard0 database, but nothing in Report DB.

Is there problem between?

============ Update 2 ============

In the log file, I can see.

DEBUG RebuildAgent: Execution started.
DEBUG ReportingStorageManager: Processing rebuild.
DEBUG ReportingStorageManager: RebuildStatus does not exist or not active yet.
DEBUG RebuildAgent: Execution finished.
  • Have you tried to rebuild reporting db once you have data in Collection.Shard0? – grg Mar 27 '18 at 12:09
  • I did a few times, but same empty.. – Jihyun Mar 27 '18 at 13:34
  • Can someone fix the title of this Q, please :P – Mark Cassidy Mar 27 '18 at 15:26
  • @MarkCassidy What do you want to change it to? I was also thinking about more specific. – Jihyun Mar 29 '18 at 13:57
  • @Jihyun were you able to resolve this issue ? i'm having exact issue on my local instance – scFootsteps Jun 6 '18 at 12:41
4

I'd suggest disabling robot detection if you are on a dev machine:

  <setting name="Analytics.AutoDetectBots" set:value="false" />
  <setting name="Analytics.Robots.IgnoreRobots" set:value="false" />
  • Thank Alex for the answer, but I already disabled those and still doesn't work :( – Jihyun Mar 23 '18 at 2:24
3

By default experience profile shows only known contacts. But to show anonymous visitors you have to enable anonymous contacts from xconnect setting and rebuild indexing.

https://doc.sitecore.net/developers/xp/xconnect/xconnect-search-indexer/enable-anonymous-contact-indexing.html

  • 1
    Thank you for the information. By enabling it, I can see updated experience profiles. But, still Experience Analytics/DeviceDetector/PathAnalyzer/etc are empty... – Jihyun Mar 27 '18 at 13:32
0

It does sound like there is a problem with your aggregation tasks. Is this a clean 9 (9.0.1?) install or an upgrade?

As noted in a previous answer, don't expect to see anything in Experience profile until you have identified some contacts. However I believe, you should still see data flow through in Experience Analytics & Path Analyzer.

Worth checking:

  • Marketing Definitions are deployed properly. Check your Solr instance by viewing Core Admin and ensuring the marketing definition indexes have documents populated. If not, redeploy your marketing definitions from the sitecore control panel and rebuild your indexes. Check the logs to make sure both of these processes don't fail in certain places.

  • There are no errors when the aggregation tasks are running (but I'm sure you would've seen that in logs already). I've seen in some migrations that the SQL user was not set correctly and needed to be manually fixed.

  • Check your path analyzer tree definitions etc are fully deployed in /sitecore/admin/pathanalyzer.aspx. They may need a rebuild too.

  • Rebuild your links databases before redeploying marketing definitions ;) As mentioned in the following answer, sometimes they do not appear to deploy properly if the links database is not up to date. Experience Analytics are not showing Online Interactions

  • I can see all documented MarketingDefinition indexes in Solr. I can't see any aggregation error in log. I tried to redeploy all maps, but it shows two errors. English Language Experience : Warning - Type field of rule element '/sitecore/system/Settings/Rules/Definitions/Elements/Visit/Visit language' is broken. and Home Landing Experience : Warning - Type field of rule element '/sitecore/system/Settings/Rules/Definitions/Elements/Visit/Entry Page' is broken. I rebuilt link DB and redeployed marketing definition, but nothing changed. – Jihyun Mar 27 '18 at 14:10
0

I am sure there is a problem on your aggregation service.

How about this quick solution:

  1. Go to your CM website folder
  2. Rename your App_Config folder to something like: App_ConfigBAK
  3. Copy the 'App_Config' folder from a CLEAN Sitecore to your website folder
  4. See if it works

If it does work then you are able to compare your app_config files with the clean ones using a tool like WinMerge.

Please let us know.

A few points to consider:

  • Data is stored on your xdb.
  • There is a default session timeout of 20 mins then the aggregation service will get the data from xdb and insert it into your reporting db on SQL server
  • Set this session timeout to 1 minute

    (web.config file line: < SessionState mode="InProc" timeout="1" ... )

  • Your Analytics needs to be working in order to have data on your SQL server

  • Make sure you abandon your session properly by closing the browser

To force your session timeout create a file called kill.aspx and put this file on your website root.

File code:

<%@ Page language="c#" %>

<!DOCTYPE html>
<html>
  <head>

  </head>
  <body>

<div>Session Abandoned</div>
<% Session.Abandon(); %>

  </body>
</html>

Force the session.abandon by accessing www.yourwebsite.com/kill.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.