7

Unicorn 3.2 Sitecore 8.2 160729

When I sync, it crashes with this error. But only on a few projects.

[A] master:/sitecore/templates/Feature/Navigation/_Navigable/Navigation/LinkTitle (230de8d4-f378-40b0-9c46-c1cfb5facf98)
    ERROR: Bad IL format. (System.BadImageFormatException)
    at Sitecore.Data.Database.GetItem(ID itemId) 
    at Unicorn.Pipelines.UnicornSyncComplete.SyncedItemPostProcessor.<>c__DisplayClass0_0.b__1(ChangeEntry change) 
    at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext() 
    at System.Linq.Enumerable.WhereEnumerableIterator`1.MoveNext() 
    at System.Linq.Buffer`1..ctor(IEnumerable`1 source) 
    at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source) 
    at Unicorn.Pipelines.UnicornSyncComplete.SyncedItemPostProcessor.Process(UnicornSyncCompletePipelineArgs args) 
    at (Object , Object[] ) 
    at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) 
    at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) 
    at Unicorn.SerializationHelper.SyncTree(IConfiguration configuration, Action`1 rootLoadedCallback, IItemData[] roots) 
    at Unicorn.ControlPanel.Pipelines.UnicornControlPanelRequest.SyncVerb.Process(IProgressStatus progress, ILogger additionalLogger)
11

Unicorn 3.2 is built against .NET 4.5, and Sitecore 8.2 is built against .NET 4.5.2. There are some funny edge cases where the earlier framework assembly calling the later framework assembly breaks - like this one.

To fix this update to Unicorn 3.3 RC9, which is built against .NET 4.5.2 and squashes a bunch of bugs. It's a plain ol' NuGet package upgrade to install it. Refer to https://github.com/kamsar/Unicorn/issues/175

  • You've got the answer from the Father of Unicorn :) – Sergey Kravchenko Oct 12 '16 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.