0

We have a custom Lucene index configured on our Content Management and Content Delivery server. The rebuild strategies on the index are

<strategies hint="list:AddStrategy"> <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/onPublishEndAsync" /> <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/remoteRebuild" /> </strategies>

The issue is that the Lucene index on the Content Management server is not in sync with the index on the Content Delivery server. The only way to keep them in sync is to manually trigger an index rebuild on the Content Management server.

Is this expected behavior or is there a misconfiguration somewhere?

1

This is expected behaviour with Lucene. For scaled architectures, you should be using Solr (or Azure Search in PaaS). See the recommendations here:

https://doc.sitecore.net/sitecore_experience_platform/82/setting_up_and_maintaining/search_and_indexing/indexing/using_solr_or_lucene

On scaled environments:

You must use Solr if you have a scaled environment.

On Lucene synchronization:

Lucene is a file based indexing system, which means if an index is not located on the server that the request is coming from you have to ensure that indexes across all servers remain in sync. This is technically possible but non-trivial, and not supported.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.