2

This is my custom Activity:

public SendPromoEmailActivity(ILogger<SendPromoEmailActivity> logger)
            : base((ILogger<IActivity>)logger)
 {

 }

 public override ActivityResult Invoke(IContactProcessingContext context)
 {
      EmailAddressList facet = context.Contact.GetFacet<EmailAddressList>();

      return (ActivityResult)new Failure("My Send Promo Email is working");
      //Logger.LogDebug("My Send Promo Email is working");
      //return (ActivityResult)new SuccessMove();
 }

I think it's working as Marketing campaign is going through.

I'd expect to receive one of these logs:

  • new Failure("My Send Promo Email is working")
  • Logger.LogDebug("My Send Promo Email is working")

Where do I get those logs of Marketing automation custom activity?

I have added activity in UI.

enter image description here enter image description here

5

As mentioned elsewhere, the log files are in [yourxconnectroot]\App_data\jobs\continuous\AutomationEngine\App_Data\Logs.

You can change the log level in: \App_data\jobs\continuous\AutomationEngine\App_Data\Config\sitecore\CoreServices\sc.Serilog.xml

If you need to debug your custom activities, do the following:

  1. Stop the service: [instancename]_automation-marketingautomationservice
  2. Open a command prompt and launch \App_data\jobs\continuous\AutomationEngine\maengine.exe
  3. Attach to maengine.exe from Visual Studio

This makes debugging a bit easier as you can start/stop the engine as you please, and you follow what the engine is doing in the console.

2

Where the Marketing Automation logs located depends how the service was installed. The one of the way how to determine where the log for marketing automation located just to find the current service in services.

enter image description here

Right mouse click and choose Properties. See "Path to executable". When you know the root location just go to "App_Data\Logs" if it was not changed in settings.

How to debug it and configure the log Jacob Nielsen has already answered.

1

Assuming everything is done correct, you will find logs in the following folder [yourxconnectroot]\App_data\jobs\continuous\AutomationEngine\App_Data\Logs

Otherwise you will find some errors there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.