1

I have a fresh installation of Sitecore 9.0.1 rev 171219 and am attempting to install SXA 1.6. I've downloaded the package and when attempting to install it, it fails with the following error in the logs:

ManagedPoolThread #7 09:11:03 INFO Installing item: items/master/sitecore/system/Modules/Layout Service/Rendering Contents Resolvers/SXA/Page List Contents Resolver/{93FC6E4C-9119-4C05-B8B5-41446A9BB5FA}/en/1/xml

ManagedPoolThread #7 09:11:03 INFO Installing item: items/master/sitecore/system/Modules/Layout Service/Rendering Contents Resolvers/SXA/Rich Text Contents Resolver/{192EFE3F-F0C8-49D0-AEED-6F233F36CCC3}/en/1/xml

ManagedPoolThread #7 09:11:03 ERROR One or more exceptions occurred while processing the subscribers to the 'item:saved' event.

Exception[1]: System.NullReferenceException

Message[1]: Object reference not set to an instance of an object.

Source[1]: Sitecore.Marketing.xMgmt

at Sitecore.Marketing.xMgmt.Definitions.ItemEventHandler.<>c__DisplayClass19_0.b__0(Guid templateId)

at System.Linq.Enumerable.Any[TSource](IEnumerable1 source, Func2 predicate) at Sitecore.Marketing.xMgmt.Definitions.ItemEventHandler.DeployItem(Item item)

at Sitecore.Events.Event.EventSubscribers.RaiseEvent(String eventName, Object[] parameters, EventResult result)

ManagedPoolThread #7 09:11:03 ERROR Failed to save the item. Item ID: {FA86AD54-9CEC-4509-9EFD-DD6DBC608A5B}, database: master

I've searched all over and cannot find a way around this issue.

Has anyone encountered this before?

Any ideas on how I can get past this?

  • is it Solr up and running? – Vlad Iobagiu Apr 4 '18 at 15:00
  • Yes Solr is running properly. There were errors previously that required a dynamicfield entry; however, Solr is running without issue now. – JamesEggers Apr 4 '18 at 15:11
  • 1
    @JamesEggers - Have you installed SPE (Powershell extensions) 4.7.2 before installing SXA? – Peter Procházka Apr 4 '18 at 16:42
  • @PeterProchazka The error disappeared after installing SPE. Thanks!! – JamesEggers Apr 4 '18 at 17:27
  • Glad I could help @JamesEggers. Definitely misleading error message. – Peter Procházka Apr 4 '18 at 17:33
1

This error could be caused by missing SPE module. Try to install Sitecore PowerShell Extensions 4.7.2 which is a prerequisite for SXA 1.6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.