I'm following given post for Sitecore 9 Set up on local machine Sitecore 9 set up

Got below error on install.ps1 execution even I'm able to browse the Solr URL( https://localhost:8985/solr/ ) successfully

enter image description here

Where should I look at further now. Any suggestion

OS: Windows 8.1 IIS: 8.5 PowerShell 5.1 Solr: 6.6.2

I tried work around from below post but no luck

SolR issue

  • 1
    Please include this error stack trace as regular text (not image), or the question has no value for this site.
    – Mark Cassidy
    Commented Apr 15, 2018 at 10:06

1 Answer 1


Try upgrading your Sitecore Install Framework to version 1.2+ and SIF Fundamentals to 1.1+. I had this same issue when I was running 1.0 of both SIF and Fundamentals. My Solr instance was definitely present because I could navigate to it, but what I found was happening, is that SIF is restarting the service that runs Solr, but I guess it doesn't restart fast enough. I noticed the newer versions of SIF and SIF Fundamentals, retries the instance a few more times before it fails, which typically on the 2nd or 3rd try it works correctly.

If you are not sure how to upgrade SIF and SIF Fundamentals, try the following:

  1. Open Powershell as an Administrator.
  2. Register a connection to MyGet feed
Register-PSRepository -Name SitecoreGallery -SourceLocation https://sitecore.myget.org/f/sc-powershell/api/v2
  1. Then type the following commands to install the latest version of each:
Update-Module SitecoreInstallFramework
Update-Module SitecoreFundamentals

That should be it. Now try to re-run Sitecore Install Framework. You can optionally also do Install-Module [Name_of_module]

You can check the version of your module by importing the module by running Import-Module SitecoreInstallFramework and then running Get-Module SitecoreInstallFramework.

  • 1
    In 1.2 we introduced a prerequest check to ensure the solr service was responding before make the actual request to manage cores. Dylan is spot on here with his answer.
    – Kieranties
    Commented Apr 14, 2018 at 7:11
  • Ok so now I'm trying to update latest SIF and tried to register SitecoreGallery but got error message: PackageManagement\Register-PackageSource : Module Repository 'SitecoreGallery' exists. so looks like connection is already established then executed Update-Module SitecoreInstallFramework and get below error: Update-Module : Module 'SitecoreInstallFramework' was not installed by using Install-Module, so it cannot be updated. I'll try Manual Installation
    – Sukhjeevan
    Commented Apr 14, 2018 at 15:37
  • Well...It's very strange. I did SIF manual installation and ran Get-Module SitecoreInstallFramework -ListAvailable command and as a result I could see SIF 1.2.0 version in power-shell after this I ran SC9 install.ps1 but getting same error --> Install-SitecoreConfiguration : Could not find Solr instance: localhost:8985/solr
    – Sukhjeevan
    Commented Apr 14, 2018 at 16:05
  • now I ran Import-Module SitecoreInstallFramework in PS and then Get-Module SitecoreInstallFramework this time I'm getting version 1.0.2 looks like manual installation was not proper...might be system reboot required
    – Sukhjeevan
    Commented Apr 14, 2018 at 16:13
  • 1
    Sure @MarkCassidy I'll mark this done because I got the solution in context of original question so installing latest SitecoreInstallFramework/SitecoreFundamentals modules worked out thanks dylan / Kieranties for you response
    – Sukhjeevan
    Commented Apr 15, 2018 at 11:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.