0

While adding a package reference to Sitecore.Commerce.Plugin.Orders, I see the following error:

NU1603: Sitecore.Commerce.Plugin.Availability 2.1.3 depends on Sitecore.Commerce.Plugin.Catalog (>= 2.1.9) but Sitecore.Commerce.Plugin.Catalog 2.1.9 was not found. An approximate best match of Sitecore.Commerce.Plugin.Catalog 2.1.10 was resolved.

What's causing this error and how can I fix it?

1

tl;dr Explicitly add Sitecore.Commerce.Plugin.Catalog 2.1.10 to the project and then re-add the intended package.

For whatever reason, Sitecore never published 2.1.9 of Sitecore.Commerce.Plugin.Catalog to the public NuGet feed instead skipping straight to 2.1.10. This becomes an issue when other packages depend on 2.1.9. When NuGet resolves downstream dependencies it won't accept the actual referenced version missing, even if the version dependency is fuzzy (>= 2.1.9 in this case). If, on the other hand, the project already references the downstream dependency and that version is acceptable then it is considered valid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.