1

We are doing automatic Azure deployments (blue/green) with .update package installations. We are using Octopus deploy to Azure, with remote Powershell script to install the .update package and do a smart publish. We deploy code, restart the app service similar to recycling the apppool, kick off .update package install and publish. We are getting the following error:

The type initializer for 'Sitecore.Install.Serialization.IOUtils' threw an exception.

If we go to the site manually, and try to install it as package thru the package installer, we get the same error. This seems to go away if we wait x amount of time. We can then install a package again.

I verified ITHit.WebDAV.Server.dll was in the bin folder. Does anyone have an idea what else it could be? Thanks.

1

The problem may be related to the situation when you are referencing DLLs in your Visual Studio project from another version than the one that is referenced by default in Sitecore.

I would recommend you to get "bin" folder from vanilla Sitecore distributive and compare it with your "bin" folder to check for any difference in DLLs.

Pay especially attention to the Mvp.Xml.dll. From my experience of observing such exception the newer version of this DLL was referenced by Nuget in VS project. When changing that to the one from Sitecore vanilla distributive, the issue was not reproducible anymore.

| improve this answer | |
  • We have since solved it by installing Sitecore first, then deploying. It is possible it was because of that dll. – RReilley Oct 2 '18 at 14:15
0

We have since solved it by installing Sitecore first, then deploying. We don't get this error after deploying, so if that dll was a diff version i would think it would still be an issue after deployment. Ivan's answer is correct I believe. It is possible in the order that we did things a new version of Mvp.Xml.dll was put in place.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.