2

Just starting messing with Sitecore Experience Platform/Commerce 9.0 update 1 on Azure's App Service, managed to deploy it fairly easily, but now I'm stuck during the bootstrap/initialization part.

As per their documentation, I've imported the "postman" folder from the root of the Commerce Engine SDK folder into Postman. I ran the GetToken call to get my SitecoreIdToken, it worked and the value got populated automatically in Postman.

Now I'm trying to run the Bootstrap Sitecore Commerce and Initialize Environment calls, but it doesn't work.

I've modified the default environment variable HostName to reflect my Azure App Service's URL, being sxc-portal-587220-ops.azurewebsites.net. I've left the protocol as https, and left everything else as-i.

When I run the command, which now expands to PUT https://sxc-portal-587220-ops.azurewebsites.net:5000/commerceops/Bootstrap() (for the Bootstrap Sitecore Commerce call), it times out. Same for the Initialize Environment call, which expands to https://sxc-portal-587220-ops.azurewebsites.net:5000/commerceops/InitializeEnvironment(environment='EnvironmentName') If I try and access the ops URL by itself (https://sxc-portal-587220-ops.azurewebsites.net), I get the following error: Status Code: 404; Not Found.

Can anyone help me regarding this issue ? Would be greatly appreciated.

Thanks!

  • have you checked authoring and ops sites log files? – josedbaez Apr 26 '18 at 11:37
2

Alright, I got the answer from Sitecore's Slack team (who reached out to Sitecore as they had the same issue). It was a mix of JuanDanielGarza's answer, and kind of not! It ended up being a simple issue of the pre-configured API calls from Sitecore that were hardcoded to use the Ops server's (not the CM instance) port 5000 for access.

The Bootstrap Sitecore Commerce API call looks like that when opened: {{OpsApiHost}}/{{OpsApi}}/Bootstrap(), while the Initialize Environment looks like this: {{OpsApiHost}}/{{OpsApi}}/InitializeEnvironment(environment='{{Environment}}').

{{OpsApiHost}} is configured as such: {{Protocol}}://{{HostName}}:5000. {{Protocol}} = https, and {{HostName}} has to be configured with your Ops App Service's URL.{{Environment}} is already populated in the two environments that you load into Postman.

enter image description here

By changing the default port to 443 instead of 5000, it worked just fine, all the redirects in the backend were taken care of by the Ops server, and my Boostrapping and initialization calls succeeded without a hitch.

0

App Services only use ports 80 and 443, the hostname would normally be your CM instance and use ports 5000 and 5050 to redirect to the other hosts like ops and minions. replace the urls in postman with the webapps for each service as opposed to using the port 5000 redirects from the primary url. additionally make sure you selecting token auth for each POST/GET

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.