2

I followed the steps in the main Sitecore site to try and make a form using Sitecore 9, here

https://doc.sitecore.net/sitecore_experience_platform/90/digital_marketing/sitecore_forms/creating_forms/create_a_new_form

However, whenever i click "save", i get an error message "an error has occurred", and it won't save.

I've checked the console, apparently every time i click "save" this error appears enter image description here

Any tips on how to fix this would be great.

3

Looking at the error it looks like the new forms in Sitecore 9 are using the Sitecore item api in order to save the form and the error your seeing is due to failing authentication.

can you use postman (https://www.getpostman.com/) to post a test to the following endpoint to try and login and see if the item api is working correctly?:

https://sitecore1.local/sitecore/api/ssc/auth/login

You should be able to import this curl command into postman:

curl -X POST \
  https://sitecore1.local/sitecore/api/ssc/auth/login \
  -H 'cache-control: no-cache' \
  -H 'content-type: application/x-www-form-urlencoded' \
  -H 'postman-token: 0de63dfb-7712-bc08-0ba0-abb85f33d855' \
  -d 'username=admin&password=b&domain=sitecore&database=master'

I'm assuming your local username and password here are admin/b so update these if not.

If the above request doesn't work make sure you set up a local self signed cert in IIS and are using Sitecore under HTTPS: https://dontpaniclabs.com/blog/post/2017/01/11/creating-self-signed-ssl-certificate-developing-testing-iis/

The item API requires requests to be under https in order to work. Once you have done this you should find the request above works.

12
  • I sent the request using postman, I got the following error response: Could not get any response There was an error connecting to sitecore1.local/sitecore/api/ssc/auth/login. – Mie ElMansy May 2 '18 at 11:17
  • Ok I've updated my answer. try adding a self signed cert and using that – Adam Seabridge May 2 '18 at 11:28
  • I've followed the steps in the link, added the certificate, but I'm still facing the same error, i still get 403 in sitecore and "could not get any response" in postman – Mie ElMansy May 2 '18 at 12:12
  • 1
    okay, so that didn't work either,,but as a last resort i tried deleting the cookies of sitecore1.local (my local site), and restarting the browser, and that finally did the trick! it works now, thanks alot! – Mie ElMansy May 2 '18 at 14:21
  • 2
    Had same issue and indeed deleting cookies helped... – Peter Procházka Oct 17 '18 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.