1

A few days ago I posted this question:- 403 Forbidden when saving form

I was facing an issue where whenever I tried to save the form,I would get the 403 forbidden error in the console. After multiple trials with the solution provided back then, I deleted the cookies of sitecore.local and suddenly saving the form worked. Little did i know that it was only temporary, I ran through the same issue today when again I tried to save a form after editing it, and I got the 403 error.

Here is the scenario I got to that always recreates the problem:

  1. Clear the cookies and sign in to Sitecore
  2. Edit Form and save works just fine
  3. Open content editor, navigate to page which will display this form (up until this point if i return to the forms editor i can edit and save just fine)
  4. Open the page that will display the form in the Experience editor

After this step, whenever I try to return to the forms editor and save an edit, it will throw the 403 error. I am forced to delete the sitecore.local cookie, and re-login whenever I want to re-edit anything in the form and view it. I have no idea how to get past this error permanently.

Edit: These are solutions i tried that worked for other people but didn't work for me, writing them cause they might help:

  1. Tried to use Sitecore under HTTPS by setting up a local self signed certificate in IIS as per this link: https://dontpaniclabs.com/blog/post/2017/01/11/creating-self-signed-ssl-certificate-developing-testing-iis/
  2. Give the website folder full control for IIS_USER from properties -> security -> edit priveleges, then performed app pool recycle in IIS

NB: As a final resort, I had to install a new instance of Sitecore for the error to go away, i will leave this question open in case someone has other solutions to try and fix the issue

Edit 2: Installing another instance didn't work for long, the error appeared yet AGAIN.. The only thing that seems to temporarily work is opening the forms tab in a browser, and navigating the rest of Sitecore in a different browser.. I've tried this where i keep the Forms page open in Edge and i navigate Sitecore from Firefox, works so far.

1
  • Could you please verify that the corresponding website folder has full control for IIS_IUSER? Also this will occur when the temp folder don't have the permission to write for IIS_IUSER. Do the above changes and do a app pool recycle. I have faced the same problem and I have fixed by doing above changes. Commented May 7, 2018 at 20:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.