7

I am having trouble configuring the analytics engine on Sitecore 9 with a pretty standard install of Sitecore XP1. I'm using the self-signed certificates and none of the analytics graphs display because of errors. I've tried some expert recommended steps to resolve it, by configuring the services to use the correct xConnect certificate (Find by thumbprint). The xdb processing site will not load. Can someone help me solve this?

I see this in the Sitecore log:

Exception: System.InvalidOperationException
Message: The certificate was not found.
Source: Sitecore.Xdb.Common.Web
   at Sitecore.Xdb.Common.Web.CertificateWebRequestHandlerModifier.Process(HttpClientHandler handler)
   at Sitecore.Xdb.Common.Web.CommonWebApiClient`1.CreateRequestHandler()
   ...

The 'processing' site log shows: Exception: System.Net.WebException Message: The request was aborted: Could not create SSL/TLS secure channel.

  • Which browser do you use? Is it latest Chrome? If yes, try Firefox and comment here if you experience the same – Peter Procházka May 9 '18 at 19:59
  • I tried this and the browser used is not the issue here. – Ree-beck May 11 '18 at 15:22
  • Go to the .xconnect site from IIS. Open the edit binding window and check whether you have any SSL Certificate selected for the site. Sometimes it shows not selected there which causes this type of issue. – Foysal May 23 '18 at 9:37
1

I had same issue before. Because some non–self-signed certificates in the Trusted Root Certification Authorities certificate store. You can follow https://stackoverflow.com/questions/26247462/http-error-403-16-client-certificate-trust-issue Hope it heplful!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.