6

I have an issue with developers editing datasources for components in a page and those components being left locked after they have saved and left the page.

Example is editor edits Page A, which has a rich text component and a datasource to an item that is located under the page (/_local/rte). When the editor edits the rich text item, Sitecore automatically locks it. This is a benefit so they do not have check it out for edit. But when the editor is complete, saves the item and even checks it in. The datasource items are left locked.

The answer seems to be to set the Sitecore setting AutomaticUnlockOnSaved to true. This causes items to unlock when saved. The only issue is that it only does this when saving an item in the content editor. NOT the experience editor. And in the content editor, it only unlocks the current item. Not the datasource items for all the components in the page.

http://sitecoreart.martinrayenglish.com/2016/02/sitecore-8x-component-datasource-item.html

Has anyone dealt with this issue before? I haven't used SXA in a while, I wonder if they solved it there, since SXA is so components based.

Seems like maybe I need to add a SaveUI pipeline processor to unlock the child items on save.

2

So the answer has a few levels to it. First make sure this setting is set to true.

<setting name="AutomaticUnlockOnSaved" value="true" /> 

Also in the Sitecore settings there is a setting specifically for admins, so they don't leave items locked. The key is

For regular users, the "Keep Lock After Save"item in the core database

<! - KEEP LOCK AFTER SAVE FOR ADMIN USERS 
    Set this value to true if you want to 
    . 
    Notice: For regular users, the "Keep Lock After Save" item in the core database will determine whether 
    to lock or not. 
    Default value: false 
->

When I denied my user role access to the core database item

/sitecore/system/Settings/Security/Policies/Page Editor/Keep Lock After Save

All my items were no longer locked after save. Perfect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.