8

Is there a way to remove all the Analytics data?

Our instance will go live soon and we would like to start capturing data afresh.

I tried rebuilding the database (secondary reporting) using the RebuildDatabase admin page.

But the Experience Analytics still shows some data like graphs, etc.

Is there any other way to achieve what I'm trying to do, like deleting records from Mongo DB etc?

Using Sitecore 8.2.

  • 1
    You can easily restore a new blank Analytics database and also, you'll need to clear the mongoDB else when aggregation will triggered, it will re-populate the data – Hishaam Namooya May 14 '18 at 14:34
5

This is quite simple, but anyway:

  1. Truncate your mongo db. (You can just clean the folder on the server)
  2. Attach a reporting database from a vanilla sitecore instance
  3. Clean the analytics index (simply rebuild it or attach one from the vanilla instance)
  4. Refresh the reporting cache (https://learnsitecorebasics.wordpress.com/tag/refresh-aggregated-data-in-reports/)
| improve this answer | |
  • Could you pls tell me how to refresh the reporting cache. I see the admin clear cache where there is only the 'clear all' button. Will that work or is there any other way. – Qwerty May 16 '18 at 10:43
  • @Qwerty no, you should follow the steps from the linked article. It is about refreshing the data that is displayed in the charts – Andrey Bobrov May 16 '18 at 14:06
4

Have you tried Analytics Database Manager?

https://marketplace.sitecore.net/en/Modules/Analytics_Database_Manager.aspx

We have used this Module many many times.

Update 1: With ADM you can clean up analytics data from a specific date range. You can clean up: Contacts, Interactions, User Agents, Devices and Form Data.

Sitecore Analytics Database Manager

Update 2: You can also detach the old reporting-db, attach a clean Sitecore.Analytics.mdf and change the connectionString to the mongo db's. Sitecore will than add the new mongo-databases from scratch.

| improve this answer | |
  • 3
    Can you add some more information on this module and how it will solve the OP's issue? Otherwise it might be considered a link-only answer. – Gatogordo May 14 '18 at 11:55
  • ADM did not work for us. After opening the UI, it kept adding error alerts - 'process failed' – Qwerty May 15 '18 at 11:28
  • 1
    Hmmm we never have had such problems with ADM. Then I would try the suggestion in Update 2 and startup with clean analytics data from scratch – monkey.dsc May 16 '18 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.