-1

We are facing a issue while adding a link to the content body and creating a new item in our application using content editor.

Exception thrown:

Web.config registration missing!

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /sitecore/shell/Controls/Rich Text Editor/Telerik.Web.UI.DialogHandler.aspx

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1590.0

Screenshot Error Message

We are using Sitecore 8.2 initial release

enter image description here

  • Can you add some clarify to your question around how you add link to content body (screenshots are best)? – Peter Procházka May 16 '18 at 4:41
  • @PeterProchazka: while creating the New Item as per screenshot and adding the link, we get the message as per screenshot – Pushpendra Vats May 16 '18 at 4:56
  • Yes, it is there but commented. I tried un-comment and checking but same issue. – Pushpendra Vats May 16 '18 at 8:43
2

It seems that following this security bulletin caused this issue. To get rid from vulnerability someone deleted Telerik handlers from web.config for CM servers. But Telerik handlers are required on CM server for all Telerik controls features, they could be removed only on CD.

You should do next steps for Sitecore 8.2:

  1. Download the ZIP archive containing the hotfix
  2. Back up the following files in your Sitecore website folder: \bin\Telerik.Web.UI.dll, \bin\Telerik.Web.UI.Skins.dll, \bin\Telerik.Web.UI.xml, \sitecore\shell\Controls\Rich Text Editor\RTEfixes.js
  3. Extract the contents of the archive to the Sitecore website folder.
  4. Open the web.config file within your Sitecore website root folder.
  5. Add the following lines within the <appSettings> node:

enter image description here

  1. Replace the placeholder text "YOUR_ENCRYPTION_KEY_HERE" with a string of characters that will be used to secure the capabilities of Telerik controls. The string should be a set of random characters and numbers, up to a length of 256 characters. We recommend a minimum of 32 characters to be used.
  2. Under the node of the section in the web.config file, add the following configuration: enter image description here
  3. Save and close the web.config file.
  4. Clear the browser cache.
  5. If you have a <machineKey> node under the section in the web.config file, generate a new Machine Key.

For more detail about issue and fixes for other Sitecore versions, please review original article.

  • HI Anton, I tried the option provided but without any luck. As per the original Article, I had commented/removed the three references but when when I removed the third reference, I was not able to open up the text editor in Sitecore. I added the third reference again and was able to open the text editor but the original issue as screenshot is not resolved. when clicked "OK" on screenshot got another error as per another screenshot added to the original question., – Pushpendra Vats May 16 '18 at 15:14
  • @PushpendraVats you should remove on CD server. On CM server it should be present, but be properly configured. – Anton May 17 '18 at 7:55
  • I had removed from CD servers and are there on CM servers but issue persist. – Pushpendra Vats May 17 '18 at 8:03
  • @PushpendraVats Can you try using developer tools in browser look on network request that is sent after attempt to add a link to the content body? – Anton May 17 '18 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.