I am setting permissions for content editors of a site. The user in question is a member of the following roles:

  • sitecore\Sitecore Client Users
  • sitecore\Author
  • sitecore\Sitecore Client Social Authoring
  • sitecore\Analytics Testing
  • sitecore\Analytics Personalization
  • sitecore\Sitecore Client Authoring
  • sitecore\Sitecore Client Designing

When this user logs in to Experience Editor and clicks the More option of a component's properties, the Edit the related item option is not shown.
See the screenshot.

Component More menu regular user

However, if I log in with a user that has the Administrator checkbox set on their "User Profile" then this option is visible.

Component More menu admin user

What security setting should I change to make the Edit the related item visible for a non-administrator user?

2 Answers 2


For this menu option to show the user must have read access to the /sitecore/content/Applications/WebEdit/Common Field Buttons/Edit related item item in the Core database or be a member of the sitecore\Sitecore Client Designing Role.


Create them under: /sitecore/content/Applications/WebEdit/Edit Frame Buttons and you'll be able to edit specific section of the component. Its in Core database.

To check what permissions navigate to /sitecore/content/Applications/WebEdit, there will be a list of granted permissions. The most granted is Client Developing, the least Authoring. Here is the snapshot List of granted roles

Bear in mind that those roles List of roles won't have this button available are restricted to see that button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.