2

On our Content Delivery server, the published URL is redirecting to the default home page of Sitecore and I need it to redirect to the SXA site home.

Are there specific steps I should take?

  • 1
    Maybe a silly question, but is SXA installed on your CD? – Gatogordo May 27 '18 at 19:37
  • Any update? I'm facing the exactly same issue. – Miguel Minoldo Jun 24 '18 at 9:46
2

The site definition (.../Settings/Site Grouping/[Site name]) contains (amongst others) the url of your site in the Host Name field - a parameter you will normally find in the sites definition of a Sitecore site. When your url maps on a wrong site, this setting is probably wrong. Note that you can use wildcards and pipes in this field (just as you would in a non-sxa host name setting).

You can also use the SXA site manager to verify the settings in a multi-site environment: https://doc.sitecore.net/sitecore_experience_accelerator/getting_started_with_sxa/tenants_and_sites/manage_multiple_sites_with_the_sxa_site_manager With the SXA site manager you can also change the order of the sites to fix hostname issues.

| improve this answer | |
  • I am adding "*" in host name in (.../Settings/Site Grouping/[Site name]) but still content delivery server not redirecting to SXA site – NAli May 27 '18 at 18:52
  • Check my comment on the question.. and verify SXA site manager. And make sure everything is published.. – Gatogordo May 28 '18 at 11:19
0

I tried above approach plus clearing cache but didn't help.

Finally, I renamed the SiteName in the node and field and then publish, and it starts appearing correct website.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.