4

I have a component in my sitecore instance called an Article Download component. One of the fields for this component is called Download Item and it is the type link (not General Link). My authors are unable to update this field so my question is three-fold:

  1. Could it have something to do with the fact that the link type is depreciated? Even when I grant administer rights on the component to the role a user is in, they do not have access to this field.

  2. What side-effects might I see if I change the type from link to General Link? I'm wondering if I can change the type without having to do too much refactoring.

  3. How can I give the authors access?

UPDATED:

Here's a screenshot of the permissions of the role on the field from the Access Viewer. enter image description here

Here's a screenshot of the permissions on the field from the security editor. I'm not sure why everything is grayed out. enter image description here

  • Can you please add here screenshot how the permissions are set for that particular field and role in Security Editor? Can you also create screenshot from Access Viewer what are effective permissions that I applied? Just follow chapter 4 from this blog post tothecore.sk/2018/05/17/… and create similar screenshots with your own items and roles. – Peter Procházka May 29 '18 at 14:47
  • Do you have other roles set on the user? – Hishaam Namooya May 29 '18 at 19:48
  • @HishaamNamooya just built-in roles which I cannot view in Sec Editor or Access Viewer. Only Admin users can edit this field. – Michael May 29 '18 at 20:33
2

The issue does appear to have something to do with the fact that this field was using a depreciated type. The Type "link" appears to only allow editing by Admins. When I changed the type to "General Link", authors were able to edit.

I don't know what sort of side effects I may expect, but so far in my testing, everything has worked fine with the only side effect being the resolution of my problem. It appears switching from "link" type to "General Link" type is perfectly safe.

0

I just ran across this issue, and like Michael said it is caused by the Link type being deprecated. However, for me, the template using the Link type was a System template in Sitecore (Templates/System/Alias). Since I didn't want to mess with a default template created by Sitecore, I solved it by adjusting the users permissions.

In the Core database, I had to give the user Read access to sitecore/system/Field types/Deprecated Types/link. That caused all of the link options to show up for them.


Core database permission change

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.