0

Our website does not create "SC_ANALYTICS_GLOBAL_COOKIE" cookie

I have looked into showconfig and can see

<processor type="Sitecore.Analytics.Pipelines.EnsureSessionContext.EnsureDevice, Sitecore.Analytics"/>

We have the VisitorIdentification tag in our layout and Tracking is enabled.

I can see the anonymous contacts and intercations created in the mongo db and Reporting database. It's just that we don't have cookie and all of them are recording as a separate entry in the database even if the request is coming from the same device and same browser

I turned below setting to true and I can see all the anonymous contacts listed in the ExperienceProfile

 <setting name="ContentSearch.Analytics.IndexAnonymousContacts" value="true"/> 

Can someone please suggest what else could be the reason?

We are using Sitecore 8.2 update 4. I can also see the cookie is present on my dev site. Thanks

  • 1
    Do you have VisitorIdentification in your layout file? – Marek Musielak May 31 '18 at 7:46
  • Or any customization that disables Tracker? – Joost May 31 '18 at 8:08
  • @MarekMusielak yes we do have the VisitorIdentification in the layout – Meenakshi May 31 '18 at 22:36
  • @Joost Tracking is also enabled – Meenakshi May 31 '18 at 22:37
  • Could it be that cookie is created for wrong domain? – Joost Jun 1 '18 at 12:26
0

Sounds silly, but is Tracking enabled in the config?

Ensure that Xdb.Tracking.Enabled is set to true

And Ensure that layouts contain the VisitorIdentification tag or MVC helper

  • We do have the VisitorIdentification tag and Tracking enabled. – Meenakshi May 31 '18 at 22:37
0

We had the below setting pointing to the wrong domain

<setting name="Analytics.CookieDomain" value="****" />

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.