0

I am getting error while inserting a new Tenant in Sitecore 9. I checked the SPE log and found below exception.

ManagedPoolThread #7 15:40:07 ERROR Cannot bind argument to parameter 'TenantTemplateLocation' because it is null.

I tried with all and none selected from the Modules list but every time, I am getting the same result.

Any pointer would highly appreciated.

3
  • Were you able to do it before or it is a fresh instance? Are you sure that you've installed everything correctly, in the right order? Jun 20, 2018 at 10:36
  • Its a fresh instance with Helixbase installed prior to commerce installation. Jun 20, 2018 at 10:55
  • As Commerce Storefront is heavily using SXA, I would say for 99,9999% that this issue is causing you trouble with creating Reference Storefront in your Commerce instance that you have reported here sitecore.stackexchange.com/questions/12385/… Jun 20, 2018 at 11:34

1 Answer 1

1

Problem is that you are using SXA version 1.7. Based on requirements from Sitecore it should be 1.6 for Sitecore Commerce 9 that you are using.

Please install SXA 1.6 instead and "Replace all" when asked.

I would also recommend you to use SQL Server 2016 SP1 instead of SQL Server 2017 as your installation might not be supported by Sitecore Support folks.

See more information about compatibility here: - https://kb.sitecore.net/articles/804595

2
  • It is not. It is an input parameter of one of the cmdlets used in scaffolding which exists there since the beginning. Jun 20, 2018 at 19:21
  • Thanks Alan. I have removed this "conspiration theory" and false assumption from my answer :) Jun 20, 2018 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.