1

My powershell script fails when I try to run it on the Azure VM. The local installation passes successfully.

Any help is appreciated :)

> [-------------------------------------------- StartAppPool :
> ManageAppPool -------------------------------------------]
> [StartAppPool]:[Start] www.myproj.local.xconnect
> 
> [-------------------------------------------- StartWebsite :
> ManageWebsite -------------------------------------------]
> [StartWebsite]:[Start] www.myproj.local.xconnect
> ********************** Command start time: 20180620161402
> ********************** PS>TerminatingError(Start-WebItem): "The running command stopped because the preference variable
> "ErrorActionPreference" or common parameter is set to Stop: The
> process cannot access the file because it is being used by another
> process. (Exception from HRESULT: 0x80070020)" ...
> Install-SitecoreConfiguration : The process cannot access the file
> because it is being used by another process. (Exception from HRESULT:
> 0x80070020) At
> C:\Projects\myproj.Sitecore.Bedrock\Release\Deployment\Local\myproj-LocalInstall.ps1:63
> char:1
> + Install-SitecoreConfiguration @xconnectParams
> + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>     + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
>     + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
  • Can you please update your question with content of myproj-LocalInstall.ps1? It is hard to determine where it fails.... – Peter Procházka Jun 21 '18 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.