0

I'm getting the following error while performing Sitecore content search:

ERROR Could not resolve type name: Sitecore.Support.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex, Sitecore.Support.181761 (method: Sitecore.Configuration.DefaultFactory.CreateFromTypeName(XmlNode configNode, String[] parameters, Boolean assert)).

I have performed the following activities before posting this question here:

  1. Checked the Log file and could not find any specific details apart from the error description.
  2. Checked by Rebuilding the indexes and all indexes are running fine after performing rebuild indexes.
  3. Tried to follow the suggestion as mentioned in the below sitecore stack exchange link but could not find the particular type name "Sitecore.Support.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex" in both Web.config as well as "Sitecore.ContentSearch.config as well:

Could not resolve type name error while performing search in Sitecore in Content tree

Can anybody please provide your suggestions/inputs on this?

Thanks and Regards

Vijayarajan Venkateswaran

3

Your exception clearly states that it cannot find Sitecore.Support.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex, Sitecore.Support.181761.

It means you have a config file which points at the Sitecore.Support.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex.

You need to have Sitecore.Support.181761.dll in your bin folder or remove the config.

| improve this answer | |
  • Thanks Marek. I have added the Sitecore.Support.181761.dll in my bin folder and it worked great. Thanks a ton! – Vijayarajan Aug 10 '18 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.