I'm facing this error and no solution so far

Installing package: Sitecore.Commerce.Engine.Connect.2.1.54.update

http://sxa.storefront.com/SiteUtilityPages/InstallPackages.aspx?package=Sitecore.Commerce.Engine.Connect.2.1.54.update Install-SitecoreConfiguration :

    One or more exceptions occurred while processing the subscribers to the 'packageinstall:items:ended' event.

ERROR Query Exception - Query:https://localhost:5000/api/Shops('CommerceEngineDefaultStorefront') - Message: An error occured while processing this request

14952 15:09:48 ERROR Authentication Error Exception: System.Exception Message: The certificate thumbprint is invalid or missing from your configuration, secure communication with the Commerce Engine is not possible.

18336 15:09:48 ERROR Commerce.Connector - There was an error retrieving the mappings from the Commerce Service 18336 15:09:48 INFO Commerce.Connector - Loaded the mapping entries - 0 Entries, 0 Parents 18336 15:09:48 INFO Commerce.Connector - Release mapping lock

Commerce Authentication Error.png Message: The certificate thumprint is invalid or missing from your configuration, secure communication ith the Commerce Engine is not possible Any Suggestions?

  • have you resolved this? I have the same issue. Commented Jun 27, 2018 at 21:00
  • Hi Dionis Takac, I could not solved that yet , I'm still looking for an solution, I will post the solution if i find, please let me know if you find as well
    – Jose Neto
    Commented Jul 5, 2018 at 17:21
  • Have anyone found any resolution for this?
    – Amitabh
    Commented Jul 25, 2018 at 8:42
  • No yet, we are still trying to solve, if you find anything, please share
    – Jose Neto
    Commented Jul 27, 2018 at 17:11
  • I just opened a Ticket on Sitecore to see if they are able to help us
    – Jose Neto
    Commented Jul 27, 2018 at 17:22

3 Answers 3


You can try to perform the following actions

Check certificateThumbprint value(certificateThumbprint value of certificate which you've created before installation) in the App_Config\Include\Y.Commerce.Engine\Sitecore.Commerce.Engine.Connect.config <certificateThumbprint>V A L U E</certificateThumbprint>

If it doesn't help, the possible approach to disable index rebuild temporarily and rebuild all indexes after Commerce is installed. To do it, you need to comment out this handler during the installation process:


 <event name="packageinstall:items:ended">
        <handler type="Sitecore.ContentSearch.Events.PackagingEventHandler, Sitecore.ContentSearch" method="OnPackageInstallItemsEndHandler" />

It executes index rebuild after each package is installed.

Guys, try this and let me know if it the issue for you

  • Worked for Sitecore Experience Commerce 9.0.2. Commented Dec 5, 2018 at 17:22
  • Also worked for Sitecore Experience Commerce 9.0.3. Commented Dec 7, 2018 at 7:29

This issue can be solved by this method.

I faced this issue, while trying to install an package which I took from Production to install on my local. You might be might be aware that Sitecore has two different db mainly: Master and web where, all sites will be pointed to web (Mainly the end user sites). For local setup, I have changed that to "master". While installing the item, it was searching for some other item(which indeed not relevant to the item which I'm installing) in web database and started to throw error. I changed the db name to master in connection string and tried to install the same package , which installed.


I am new to sitecore so can't explain that much. But what i know was while creating a media package there was file with too long name. and while installing the package i was facing this issue.

So this link helped me out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.