4

The existing Sitecore instance has bucket items with default structure 'yyyy/MM/dd/HH/mm'. I've tried to copy bucket items into new Sitecore instance. But the new instance structure looks flat. I can see all structure in new instance but not in tree format. The functionality is working fine.

Please suggest to make the content tree structure in the new instance.

Old instance

enter image description here

New Instance

enter image description here

  • How did you copied them from one instance to another? – Marek Musielak Jun 23 '18 at 13:13
  • Created a package using Package Designer and imported using Installation Wizard option. – venkat Jun 23 '18 at 13:38
  • In old and new instance what is this setting BucketConfiguration.BucketFolderPath set to? Can be found in ShowConfig.aspx. Are they the same? Do you have on old instance custom rules implemented for your template and buckets and you just forgotten to deploy it to new instance? See further info info -> doc.sitecore.net/sitecore_experience_platform/developing/… – Peter Procházka Jun 23 '18 at 18:53
  • BucketConfiguration.BucketFolderPath is same in both instances (<setting name="BucketConfiguration.BucketFolderPath" value="yyyy\/MM\/dd\/HH\/mm"/>). There is no custom rule implemented. – venkat Jun 24 '18 at 9:59
  • Venkat, I am running into similar issue. Have you find any solution? I have tried above suggestions but no luck. Thanks, – Discovery May 3 '19 at 14:49
3

I see three options.

1. Sync your bucket again

  1. Navigate to your bucket root
  2. Click Sync button in CONFIGURE section

enter image description here

If the first step will not work you have to check if both instances have the same bucket path settings

2. Copy Item Buckets Settings

  1. Find item: /sitecore/system/Settings/Buckets/Item Buckets Settings
  2. Compare Rules for Resolving the Bucket Folder Path field on two instances. Settings there should be the same

enter image description here

3. Custom Bucket Rules

There is also a third option. If you use some custom bucket rules (Sitecore setting BucketConfiguration.DynamicBucketFolderPath) make sure they are deployed on both instances.

  • Thanks Peter for details. I verified above three options, both instances look same. Sitecore.Buckets.config file also same in both instances. It seems there is a problem with configuration somewhere. I'll check. – venkat Jun 24 '18 at 10:06
  • I just slightly edited Alan's answer :) Credit goes to him :) – Peter Procházka Jun 24 '18 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.