1

I am trying to install Sitecore Commerce with following version details:

  1. Sitecore 9.0.2 rev. 180604 (OnPrem)_single.scwdp
  2. Solr 6.6.3
  3. SQL Server 2016 Express (13.0.4001)
  4. Sitecore.Commerce.2018.03-2.1.55
  5. Sitecore PowerShell Extensions-4.7.2 for Sitecore 8
  6. Sitecore Experience Accelerator 1.6 rev. 180103 for 9.0

I am following steps mentioned in this blog

https://buoctrenmay.com/2018/03/09/step-by-step-guide-for-sitecore-commerce-9-installation-on-your-machine/

The script adds 2 databases and 6 IIS sites for the Commerce server, adds the modules to Sitecore instance and breaks at point when Commerce connector tries to access the Commerce API and maybe add the catalog. Following error is seen on the Powershell console.

Importing Module => InitializeCommerce

[---------------------------------- DisableCsrfValidation : DisableCsrfValidation ----------------------------------]

[--------------------------------------- GetIdServerToken : GetIdServerToken ---------------------------------------] Get Token From Sitecore.IdentityServer Install-SitecoreConfiguration : Service Unavailable Service Unavailable HTTP Error 503. The service is unavailable. At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\1.2.1\Public\Install-SitecoreConfiguration.ps1:253 char:21 + & $entry.Task.Command @paramSet | Out-Default + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration [TIME] 00:00:01 Transcript stopped, output file is E:\sc9_com_install\SIF\CommerceEngine.Initialize.180623.log Install-SitecoreConfiguration : Service Unavailable Service Unavailable HTTP Error 503. The service is unavailable. At E:\sc9_com_install\SIF\sc9_com_install.ps1:81 char:2 + Install-SitecoreConfiguration @params + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration [TIME] 00:39:07 Transcript stopped, output file is E:\sc9_com_install\SIF\Master_SingleServer.180623.log Invoke-RestMethod : Service Unavailable Service Unavailable HTTP Error 503. The service is unavailable. At E:\sc9_com_install\SIF\Modules\InitializeCommerce\InitializeCommerce.psm1:73 char:17 + ... $response = Invoke-RestMethod $UrlIdentityServerGetToken -Method Post ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-RestMethod], WebE
xception + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeRestMethodCommand

Also if I try to hit the URL for Commerce Authoring, the app pools(if it is already running) stops and the site throws service unavailable 503 error.

Have anyone faced this issue or know the solution?

P.S. I have x64 system with windows 10 installed and have almost all .net frameworks SDK installed along with DotNetCore.2.0.5-WindowsHosting also installed

  • Did you install the URL-rewrite module and did you check if you can login with the credentials that are configured for the related application pools? – Jonne Kats Jun 26 '18 at 8:55
  • @JonneKats, URL Rewrite, yes, credentials check no... I had changed the password in cofig, but user was already present and password remained old, so that was the issue for 503. Thanks. Now I see 400 error while installation but via postman its working fine... hopefully it will get resolved soon. Can you post it as answer so that I will accept it as correct one – Chaitanya Gadkari Jun 26 '18 at 11:38
  • Did you install Visual C++ Redistributable for Visual Studio 2015 ? – Maykon Jun 26 '18 at 13:27
3

It seems that the local account user you have used for the application pool do not have sufficient access or the credentials are incorrectly entered for the user.

Please refer this blog post for troubleshooting. https://himadritechblog.wordpress.com/2018/03/10/yet-another-sitecore-commerce-9-installation-blog-post/

It mentions that the service unavailable error occurs if user do not have access

From the above link

If you had installed Sitecore Commerce before in your machine and the account CSFndRuntimeUser existed before the installation, it might have a different password than the one used by the installation script to create the SitecoreIdentityServer website. In this case you might see the following error because the App Pool for SitecoreIdentityServer will be stopped for incorrect password. Service Unavailable HTTP Error 503. The service is unavailable.

If you are installing the Sitecore Commerce 9 in C:\inetpub\wwwroot folder, script might fail to grant permission to CSFndRuntimeUser account to the folder. If that happens, you can resolve the issue by manually granting permission and re-run the script again.

2

To add to the answer above, you said you're attempting to install Sitecore.Commerce.2018.03-2.1.55 against Sitecore 9.0.2 rev. 180604 (OnPrem)_single.scwdp which isn't supported.

That version of XC is 9.0.1 and needs to be installed against Sitecore 9.0.1, not 9.0.2 like you listed.

Commerce 9.0.2 is due for release shortly, but for now you need to stick with Sitecore 9.0.1

  • Thank you so much Rob! I was able to install commerce on Sitecore 9.0.1. It timed out at rebuild index though. Not sure if anything was remaining, will check and update, but as of now can see storefront site working – Chaitanya Gadkari Jun 27 '18 at 12:21
0

Adding to @Jonne-Kats answer:

In order to resolve this issue, I had to add CSFndRuntimeuser to the local administrators group. This was part of the old 8.2.1 installation steps:

The instructions in this document assume the existence of a local administrator account named CSFndRuntimeUser. Add this account to your local administrator group, and grant the account login permissions for the SQL server.

http://commercesdn.sitecore.net/SitecoreCommerce/DeploymentGuide/en-us/index.html#Concepts/c_M_DeploymentCreateLocalAccount.html

This step does not appear to be part of the EnsureLocalUser SIF task created in \SIF.Sitecore.Commerce.1.1.4\Modules\WindowsLocalUser\WindowsLocalUser.psm1.

I found that the Identity Service was shutting down its Applicatin Pool, and the following warning was appearing in the Windows System log (visible in Event Viewer):

The identity of application pool SitecoreIdentityServer is invalid. The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request. If batch logon rights are causing the problem, the identity in the IIS configuration store must be changed after rights have been granted before Windows Process Activation Service (WAS) can retry the logon. If the identity remains invalid after the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number.

The security policy Log on as a batch job is assigned to Administrators, so adding CSFndRuntimeuser to the Administrators group resolved the issue.

The steps for updating the account are documented here:https://www.smartftp.com/support/kb/how-to-give-a-user-log-on-as-a-batch-job-rights-f2691.html

There are security implications, of course, which are discussed here:https://docs.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/log-on-as-a-batch-job

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.