1

I installed the Sitecore Commerce 9 update 1. I followed steps from this site

https://buoctrenmay.com/2018/03/24/step-by-step-guide-for-sitecore-xc9-update-1-installation-on-your-machine/

After successfully installed powershell script without errors, I tried to open storefront.local/ site and managed to see demo site. However, when I try to open Experience Editor I don't see items from the demo site, I just see empty Experience Editor. Check screenshots.

enter image description here

enter image description here

When I open storefront.local/ and do search, I get error page "There is no method 'FacetOn' on type 'Sitecore.ContentSearch.Linq.QueryableExtensions" I assume that something is wrong. I think I did post installation steps correctly. Can anyone help me with this?

1

That error message usually means that your SOLR indexes are paused. You can check their state using the sitecore powershell tools. You can also check the search log to see if there are any SOLR connection errors.

It's a super weird error, but when the indexes are paused Sitecore uses a normal collection for the IQueryable, which isn't supported by the FacetOn extensions method.

| improve this answer | |
  • I checked search log but no errors there. – Dionis Takac Jun 26 '18 at 12:35
  • Did you check if your indexes were paused? – Jonne Kats Jun 26 '18 at 12:52
  • I solved the issue with solr indexes but my Experience Editor is still empty. – Dionis Takac Jul 2 '18 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.