I have a Pass Powershell Arm installed Sitecore 9.0.1 XP1 install. Verified that analytics were working (Collecting and reporting visits in the Experience Analytics Dashboard. We installed DNS CNAME entries and corresponding SSL certificates for the new domain names and we are now getting 500 server errors on the Experience analytics pages. Has anyone encountered this? Is there another step required to configure XConnect for the new DNS names?

  • Can you check your logs and report what the errors are? – Dylan Young Jun 27 at 6:00
up vote 1 down vote accepted

Check the WEBSITE_LOAD_CERTIFICATES application setting in on your app service in azure. It should correspond to the certificates used by xConnect and not your custom certificates. You can also set this value to * to load all the certificates. enter image description here

Be aware that these settings are filled in by the ARM templates and scripts. So you may need to adapt your script. Our script got corrupted by adding a second certificate because the call to fetch the certificates returned an array instead of the single certificate. We had to adopt the script.

The value should correspond with the value in your connection string. StoreName=My;StoreLocation=LocalMachine;FindType=FindByThumbprint;FindValue=<<some-value>>;AllowInvalidClientCertificates=true

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.