1

Is there any way to attach two SXA sites from one Sitecore instance (IIS instance) to different port number of one domain name? For example:

I tried by:

  • Added new binding with port 4502 in IIS
  • Added host name as ABC.com:4502 in sxa site manager

But when I am trying to access http://ABC.com:4502 then it's rendering default site which are on port 80 i.e. http://ABC.com.

  • I'm also facing same issue. When we hit "ABC.com:4502" in browser. it try to find "ABC.com" host name only without port number in sxa site manager and not considering "ABC.com:4502". it seems "ABC.com:4502" is invalid entry in sxa site manager. so is there any configuration that can make it valid entry or any suggestion. – Erwin Paul Jun 29 '18 at 10:31
2

Sitecore has the ability to define port within the node for it's sites.

While SXA does not have an explicit entry to put the port in, the "Site definition" item is the SXA's equivalent of this and has an ability to provide those additional properties even if the SXA team wasn't aware of a property that should be there.

The following screenshot should give you the idea how:

How to define site port in SXA

  • Thanks for the information. I will try and let you know. – Amit Kumar Jun 29 '18 at 14:03
  • Able to access 02 sxa sites on same domain name with different ports: 1. Added the different binding in IIS: abc.com with port 80 abc.com with port 4502 2. Go to SXA site manager: For Site1 add the host name as "abc.com" For Site2 add the host name as "abc.com" and add the other properties as "port" with value 4502 3. Publish both Sites entries in SXA site manager 4 With the above settings able to access sites: Site1 -> abc.com Site2 -> abc.com:4502 – Amit Kumar Jul 2 '18 at 4:12
  • This doesn't appear to work for the Minicart links in Commerce Accelerator. – Dan Solovay Apr 5 at 17:21
  • Can confirm with DotPeek that Commerce Experience Accelerator class Sitecore.Commerce.XA.Foundation.Common.UrlManager.StorefrontUrlManager does not take port number into account. I am reporting as a bug to Sitecore Support. – Dan Solovay Apr 5 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.