Using SXA 1.6 and Sitecore 9.0.1 , we have an environment with single tenant and multi sites ex: site1 , site2 ,.. we setup OOB security so only users in site1 can edit their content only and same for site2 , however we notice when a user in site1 publish his work, the content in site2 get published too

  • how we can resolve this issue?
  • what is the best practices in content approval in multi site scenarios? enter image description here

enter image description here

1 Answer 1


You would need to set Publishing.CheckSecurity to be true to prevent users from publishing content that they don't have access to (Items will be published only if the user have write access, and will be deleted if the user have delete access)

        Check security rights when publishing?
        When CheckSecurity=true, Read rights are required for all source items. When it is
        determined that an item should be updated or created in the target database,
        Write right is required on the source item. If it is determined that the item
        should be deleted from target database, Delete right is required on the target item.
        In summary, only the Read, Write and Delete rights are used. All other rights are ignored.
        Default value: false
        <setting name="Publishing.CheckSecurity" value="false" />

I would recommend you have workflow enabled on your content, you can have different workflow for each site, this will restrict publishing content that has not been approved yet, it would also help if your workflow has an auto publish action when the item is approved.

  • When I set this to true I found that it seems to skip all items even items users just created and nothing get published using Site user Jul 2, 2018 at 12:04
  • Does the user you are using to publish have write right on the root item? Jul 2, 2018 at 13:27
  • i have added image in the thread Jul 2, 2018 at 17:12
  • 1
    What do you see if you used access viewer? Jul 3, 2018 at 1:19
  • i uploaded screenshot from access viewer ? Jul 3, 2018 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.