Currently I've setup the XP1 successfull, it is up and Running and here is my Setup: enter image description here So now I am trying to install Sitecore XC Update 1 on this setup.

  • the only knowledge I have so far that I need to install the XC on my CM and CD's
  • I couldn't find any help on the sitecore site, what is strange because they are selling the hole thing and not too cheap

Some hints to my Installation configuration

  • I've removed the "EnsureLocalUser" Task in the "CommerceEngine.Deploy.json" because I am using a Domain User, this domain user exists on my SQL Server and has sysadmin rights

  • I've removed the Task "InstallSolrCores" in the "Master_SingleServer.json" because I've installed them directly on the SOLR Server

  • I've removed the "DO_NOT_TRUST_" from all json files and added my Root CA Thumbprint to all "RootCertFileName" DefaultValues

My XP0 Installation from XP and XC I've done with this documentation: https://buoctrenmay.com/2018/03/24/step-by-step-guide-for-sitecore-xc9-update-1-installation-on-your-machine/

And I was hoping that I could use the same Installation Script with some changes to the Certificate, ....

    #Requires -Version 3
    [string]$SitePrefix = "Sitecore",
    [string]$ScInstallDirectory = "C:\inetpub\wwwroot\",
    [string]$SiteHostHeaderName = "SitecoreCm.staging.com",
    [string]$SqlServer = "mssql1.staging.com\Staging21",
    [string]$SqlDbPrefix = "Sitecore",
    [string]$CommerceEngineCertificatePath = "..\xcommerce.cer",
    [string]$CommerceSearchProvider = "SOLR",
    [string]$SolrUrl = "https://01sitecore1.staging.com:8983/solr",
    [string]$SolrRoot = "c:\solr\solr-6.6.2",
    [string]$SolrService = "solr-6.6.2"

    $global:DEPLOYMENT_DIRECTORY=Split-Path $MyInvocation.MyCommand.Path
    $modulesPath=( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "Modules" )
    if ($env:PSModulePath -notlike "*$modulesPath*")
        $p = $env:PSModulePath + ";" + $modulesPath

    $params = @{
            Path = Resolve-Path '.\Configuration\Commerce\Master_SingleServer.json' 
            SiteName = $SiteHostHeaderName
            SiteHostHeaderName = $SiteHostHeaderName 
            InstallDir = "$($ScInstallDirectory)\$($SiteHostHeaderName)"
            XConnectInstallDir = "$($ScInstallDirectory)\$($SitePrefix).xconnect.local"
            CertificateName = "8C41C6BE5471128081E32BE5B0440D8EBEC42B1"
            CommerceServicesDbServer = $SqlServer    #OR "SQLServerName\SQLInstanceName"
            CommerceServicesDbName = "SitecoreCommerce9_SharedEnvironments"
            CommerceServicesGlobalDbName = "SitecoreCommerce9_Global"       
            SitecoreDbServer = $SqlServer            #OR "SQLServerName\SQLInstanceName"
            SitecoreCoreDbName = "$($SqlDbPrefix)_Core"
            SitecoreUsername = "sitecore\admin"
            SitecoreUserPassword = "whose-alley-dingo-born-lip"
            CommerceSearchProvider = $CommerceSearchProvider
            SolrUrl = "$($SolrUrl)"
            SolrRoot = "$($SolrRoot)"
            SolrService = "$($SolrService)"
            SolrSchemas = ( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "SolrSchemas" )
            SearchIndexPrefix = ""
            AzureSearchServiceName = ""
            AzureSearchAdminKey = ""
            AzureSearchQueryKey = ""
            CommerceEngineDacPac = Resolve-Path -Path "..\Sitecore.Commerce.Engine.SDK.*\Sitecore.Commerce.Engine.DB.dacpac"       
            CommerceOpsServicesPort = "5015"
            CommerceShopsServicesPort = "5005"
            CommerceAuthoringServicesPort = "5000"
            CommerceMinionsServicesPort = "5010"        
            SitecoreCommerceEngineZipPath = Resolve-Path -Path "..\Sitecore.Commerce.Engine.2*.zip"     
            SitecoreBizFxServicesContentPath = Resolve-Path -Path "..\Sitecore.BizFX.1.1.9"     
            SitecoreIdentityServerZipPath = Resolve-Path -Path "..\Sitecore.IdentityServer.1.*.zip"
            CommerceEngineCertificatePath = Resolve-Path -Path "$($CommerceEngineCertificatePath)"      
            SiteUtilitiesSrc = ( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "SiteUtilityPages" )  
            HabitatImagesModuleFullPath = Resolve-Path -Path "..\Sitecore.Commerce.Habitat.Images-*.zip"    
            AdvImagesModuleFullPath = Resolve-Path -Path "..\Adventure Works Images.zip"    
            CommerceConnectModuleFullPath = Resolve-Path -Path "..\Sitecore Commerce Connect*.zip"  
            CEConnectPackageFullPath = Resolve-Path -Path "..\Sitecore.Commerce.Engine.Connect*.update"
            PowerShellExtensionsModuleFullPath = Resolve-Path -Path "..\Sitecore PowerShell Extensions*.zip"
            SXAModuleFullPath = Resolve-Path -Path "..\Sitecore Experience Accelerator*.zip"
            SXACommerceModuleFullPath = Resolve-Path -Path "..\Sitecore Commerce Experience Accelerator 1.*.zip"
            SXAStorefrontModuleFullPath = Resolve-Path -Path "..\Sitecore Commerce Experience Accelerator Storefront 1.*.zip"
            SXAStorefrontThemeModuleFullPath = Resolve-Path -Path "..\Sitecore Commerce Experience Accelerator Storefront Themes*.zip"
            SXAStorefrontCatalogModuleFullPath = Resolve-Path -Path "..\Sitecore Commerce Experience Accelerator Habitat Catalog*.zip"
            MergeToolFullPath = Resolve-Path -Path "..\Microsoft.Web.XmlTransform.dll"
            UserAccount = @{
                Domain = "mydomain"
                UserName = '21-sitecore'
                Password = 'thepassword'
            BraintreeAccount = @{
                MerchantId = ''
                PublicKey = ''
                PrivateKey = ''
            SitecoreIdentityServerName = "SitecoreIdentityServer"       

    if ($CommerceSearchProvider -eq "SOLR") {
        Install-SitecoreConfiguration @params
    elseif ($CommerceSearchProvider -eq "AZURE"){
        Install-SitecoreConfiguration @params -Skip InstallSolrCores

My current problem is, that the setup can't restart the SQL Server. SQL Server is installed on a another machine.

This is a strange issues as on my Dev Setup the SQL Server is also on another machine, and here I don't get this error.

Error Message in English: "Cannot validate argument on parameter ‘InputObject’.

The argument is null or empty. Provide an argument that is not null or empty, and then try the command again."

enter image description here

So, the Problem with the Cannont validate I've "solved" so far.

  • the Problem was that I've restarted the Installation Script again and when you restart it, it tries to delete all the websites when they are existing and then it tries also to restart the SQL Server. My first Solution is that I've manually removed all XC Websites which where created so far.

And I think now I've found my error why there are no commerce databases created on the SQL Server.

enter image description here

But I only have the German Error Text :-/

  • the second error seems to be a problem with the SQL Server, perhaps a restart help here. I've just tried to install it again on the next morning and the error was gone.

My next Error is on "InstallModule" I get a 403.0 error when trying to install the Sitecore PowerShell Extensions-4.7.2 for Sitecore 8.zip

enter image description here

When I try to call this size directly on the Browser I get the same error

enter image description here

  • Solution for the 403.0 Error was that the page only was avaible with HTTPS when I was calling the page with HTTPS it was working, so I've modified the "master_singleServer.json" from http to https

     "UtilitiesBaseUrl": "[concat('https://', concat(parameter('SiteHostHeaderName'), '/SiteUtilityPages'))]",

problem: "EnsureSyncDefaultContentPaths"

Descriped here: Ensure/Sync default content paths for environment AdventureWorksAuthoring failed during SXC installation

But I don't know what to fill into the config.json files and into which files, because when you search in the wwwroot I got 8 result.

enter image description here

when I look into the IIs Log I see what URL is called in here seems everything ok and I've also called the funktion called with Postman but I don't know if this is the right result

enter image description here

Setting up web.config and Sitecore.ContentSearch.config

  • I also hat to manipulate the web.config I had commented out the following rule for the installation after it comment it in again

     <rule name="Forbidden" enabled="true" stopProcessing="true">
        <match url="(.*)" />
        <add input="{HTTPS}" pattern="^OFF$" />
        <add input="{HTTP_METHOD}" pattern="GET" />
      <action type="CustomResponse" statusCode="403" subStatusCode="0" />
  • In the file C:\inetpub\wwwroot\\App_Config\Sitecore\ContentSearch/Sitecore.ContentSearch.config comment out the event

     <event name="packageinstall:items:ended">
       <handler type="Sitecore.ContentSearch.Events.PackagingEventHandler, Sitecore.ContentSearch" method="OnPackageInstallItemsEndHandler" />

After this Changes the Installation on my CM was successfull

If you need more information about my setup please tell me what you need to know

  • Can you check whether user that is running PS scripts have admin rights on SQL Server? Also do you have access to SQL Server from server that you are running PS script (is it whitelisted, ...)? Commented Jul 4, 2018 at 12:30
  • @PeterProchazka I've added some more Informations above. The Domainuser who is accessing the SQL Server is sysadmin on the SQL Server. Commented Jul 4, 2018 at 12:34
  • Try to clean up environment before running initial environment command from postman Commented Jul 10, 2018 at 7:48
  • Which version of SXA have you installed? Commented Jul 10, 2018 at 7:49
  • I've installed SXA 1.6 Commented Jul 10, 2018 at 8:18

1 Answer 1


I've added all Answers to my initial Post and I got it working on my CM with this settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.