1

We are trying to install the following NuGet package: Microsoft.IdentityModel.Protocols.OpenIdConnect

However, we are being blocked by this error message:

Error Unable to find a version of 'Microsoft.Extensions.Configuration' that is

compatible with 'Microsoft.Extensions.Configuration.CommandLine 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)', 'Microsoft.Extensions.Configuration.EnvironmentVariables 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)', 'Microsoft.Extensions.Configuration.FileExtensions 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)', 'Microsoft.Extensions.Configuration.Ini 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)', 'Microsoft.Extensions.Configuration.Json 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)', 'Microsoft.Extensions.Configuration.Xml 2.1.1 constraint: Microsoft.Extensions.Configuration (>= 2.1.1)'.

Since Sitecore relies on this Microsoft.Extensions.Configuration NuGet package, we cannot remove it.

How do we get back to a state, where we can add NuGet packages?

  • Which version of Microsoft.IdentityModel.Protocols.OpenIdConnect are you trying to install? Have you checked if some older version is compatible with Microsoft.Extensions.Configuration? – grg Jul 6 '18 at 11:42
  • I checked if any of the older versions were compatible, but then I got the same error as in the question, just for a lower version of Microsoft.Extensions.Configuration - (1.0.0 I think). I was trying to install Microsoft.Owin.Security.OpenIdConnect v. 3.1.0 – Hos Jul 6 '18 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.