2

I am running Sitecore 9 update 2 locally and trying to work with the experience profile. In the analytics, I see activity data but when I go to the profile screen I get no records. All my visits so far are anonymous. I tried to rebuild the reporting database and get this error.

Connection string used by aggregation/reportingStorageManager/ReportingTargetConfigPath is missing.

Based on my reading rebuilding the reporting database is the first step in troubleshooting this but I am not sure how to solve this error. I have searched the showconfig.aspx results but nothing in there is helping me.

Any insight?

Update 1

After digging into this more it sounds like a secondary reporting database should not be needed for this screen to work. So the error about rebuilding indexes is really not related as the secondary is needed for the rebuild but not for the experience profile screen.

As the comments call out I did have an error in the xconnect and application logs about access to the Global counter. I have resolved that and now both logs show no errors. There are also no console errors being shown. Here are the logs I have checked.

xConnect web app: xconnect log file

Application webapp : log, Exm, Search, Crawling, Publishing

Automation server log

Indexing Log

  • Do you have the secondary connection string set? check this doc.sitecore.net/developers/xp/reporting/rebuild-reporting.html – Naim Alkouki Jul 12 '18 at 17:33
  • I do not. I was just about to work on that but is a secondary reporting database really need for experience profile screen to render anything? The secondary is needed to rebuild the reporting database it seems but is it really needed to use experience profile screen locally? – ToddB Jul 12 '18 at 18:23
  • If you want to rebuild the reporting database, you will need to add the secondary connection string. Secondary connection string is not required to view the experience profile. Moreover do you have any errors in logs or console when loading the experience profile? – Hishaam Namooya Jul 12 '18 at 21:07
  • Thanks @HishaamNamooya. I have not found any error in any of the following: log.txt, Exm.log.txt, Search.log.txt, Crawling.log.txt. Is there a log I am maybe not checking? Also is there a delay between events and when a contact would show up (like 24 hours)? – ToddB Jul 13 '18 at 3:04
  • I take that back. I just looked in the xConnect logs and see System.UnauthorizedAccessException: Access to the registry key 'Global' is denied. – ToddB Jul 13 '18 at 3:06
4

After digging around and getting more familiar with all this I have figured out what was going on. There are a couple of things to understand here.

1) In Sitecore 9 indexing of anonymous contacts is disabled by default. I had tried to turn this on but had missed a couple steps. I found all the steps I needed in the answer to another thread.

2) If anonymous contacts are not enabled you have to make sure you call the IdentifyAs method for the request. If not the request will be anonymous and if you don't have those enabled nothing will show. Here is a blog post breaking all this down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.