1

I noticed that lately when I log into a Sitecore instance in Firefox and view the showconfig.aspx, it does not appear in XML, rather as a string of randomly jumbled words, paths and IDs.

enter image description here

If I open showconfig in Firefox private mode I get the same result. In the Firefox browser console I see the following:

XML Parsing Error: not well-formed
Location: 
Line Number 1, Column 129:

However, if I log into Sitecore in Chrome and open showconfig there, it shows the same jumbled mess for a split second, then it shows the XML structure just fine, and no XML related console errors (one favicon.ico 404 is all).

enter image description here

I've tested this with a clean 8.2 rev 170728 instance and a "clean"/unaltered instance of Habitat (same Sitecore version). I am using the latest version of Firefox (61.0.1 right now) and the latest version of Chrome.

7
  • 1
    Tried this on both an 8.0u7 and 8.2u7 install with FF61 and both displayed the showconfig page as expected (similar to your Chrome screenshot). Perhaps the issue is due to a plugin or setting change you previously made. Maybe use a portable version of Firefox to rule it out...
    – jammykam
    Jul 17 '18 at 2:30
  • what happens if you hit "ctrl + u" on the showconfig.aspx in firefox. Does it look normal now?
    – JKerny
    Jul 17 '18 at 5:41
  • 1
    Have you tried to download showconfig output and see what is in Line Number 1, Column 129? Jul 17 '18 at 5:47
  • I think that your config is obfuscated and Chrome gracefully fails without any error. Firefox unfortunately not. Try to see what is on line 1 column 129 in Notepad++ when you copy and paste generated xml. If this doesn't help try to disable some of your custom config files. Maybe the issue relies there. Jul 17 '18 at 7:59
  • @PeterProchazka How would the config be obfuscated? This is not OOTB behaviour (and any customization would be extensive). More likely the browser is interpreting the results as HTML (i.e. check the Response header Content-Type: text/xml)
    – jammykam
    Jul 17 '18 at 14:07
2

The Showconfig.aspx page should work in all browsers, and Firefox is listed on the Sitecore Compatibility table as a supported browser.

I have confirmed this using Firefox 61 on both Sitecore 8.0 update-7, Sitecore 8.2 update-7 and Sitecore 9.0 update-1.

This would suggest it is not an issue with Sitecore but an issue on your local install of Firefox. To try and debug the issue I would suggest:

  • Try in a private browsing window
  • Try using a portable version of Firefox.
  • If this works, then issue is something to do with your local install of Firefox. Try disabling all extensions you may be using.
  • If that succeeds then re-enable each extension one by one until you find the plugin that is causing the issue.
  • You could also try to refresh Firefox, which effectively resets all settings and add-ons.

As noted in the comments, the issue was due to an extension which was intefereing with the rendering of the config page/xml documents.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.