Anyone know why my Experience Analytics dashboard in Sitecore 8.1 Update-3 would be blank like this?

EDIT: in the network console for my browser I am seeing the following error:

enter image description here

enter image description here

  • Which Sitecore version?
    – Mark Cassidy
    Oct 13, 2016 at 14:44
  • Sorry. Added version to original question. Oct 13, 2016 at 14:45
  • 1
    Can you please check network or console tabs and see if there are 404s there
    – josedbaez
    Oct 13, 2016 at 14:45
  • Are you using any Dependency Injection? How are you adding it? Are you using any chained fallback for your containers?
    – jammykam
    Oct 13, 2016 at 14:46
  • No 404s in the console but there is a JS error. I attached a screen shot. Oct 13, 2016 at 14:55

4 Answers 4


When a user browses the site, the session/interaction is tracked in MongoDB.

When a session ends (due to inactivity and controlled by the timeout in the web.config), the commitSession pipeline kicks in and then the aggregation is done.

Once the data is aggregated it is immediately available in the Experience Analytics dashboard. However, Experience Analytics caches the data, so you may have to wait a while before you can see it.

You can change the cache settings in Sitecore.ExperienceAnalytics.WebAPI.config. The settings you should be looking at are these:

<patch:attribute name="cacheEnabled">false</patch:attribute>
<setting name="ExperienceAnalytics.Api.CacheExpiration" value="00:00:00" />
<setting name="ExperienceAnalytics.InternalCacheExpiration" value="00:00:00" />

Note in this example I have effectively disabled the cache. Don't do this in production environments.

Another thing which might have an impact on your data is this setting

<setting name="ExperienceAnalytics.Aggregation.SegmentDeployDateOffsetPadding" value="00:30:00" />

in Sitecore.ExperienceAnalytics.Aggregation.config. When you install Sitecore a number of Segments are deployed in the Segments table in the reporting/analytics database. The deploy date of these segments control what data will be aggregated. As an example: If you install Sitecore at 12:00 on the 12th of 2012, any interactions before this time will not be aggregated.

  • this was work for me, i have to wast 3 hours to find this :) thank you guys Nov 19, 2018 at 13:03

It turned out that I just need to clear my browser cache. Once I did that then the dashboard loaded properly.


There are several reasons why it could be blank:

  1. You just installed the Site, and the agent that aggregates the data has not run yet (it only runs 1 time per day, and does not include the current day's traffic).
  2. You have incorrectly configured your separate processing and aggregation server and it's trying to aggregate the wrong data (been there, done that :) ).
  3. You don't have MongoDB connections setup correctly, and so you don't have any data coming into your MongoDB. The Processing and Aggregation services look at the records collected in MongoDB. If you don't have any records there, you won't have any data in your aggregation. Check the Interactions Collection in your Analytics Database. If there isn't any data, then something is wrong with your MongoDB setup.

Those are the first three things that I can think of for you to check. What I've done in the past is install a new instance of Sitecore, make sure that the Analytics are working, and then compare configs to see what is different.

I hope that this is helpful for you!

  • I agree with 2 and 3, but unless I'm missing something 1. is wrong. See my answer Oct 26, 2016 at 8:51

I'm guessing you're in Chrome, and on a Sitecore version that requires Microsoft Silverlight. I think you need 8.2 before the requirement for Silverlight goes away.

  • I don't think that is it. On my local developer box I am using Chrome and that page seems to function fine. Oct 13, 2016 at 14:46
  • The Experience Analytics dashboard in 8.1 update 3 (and probably earlier versions as well) do not require Silverlight Oct 26, 2016 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.